summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2009-09-09 17:01:49 -0600
committerRich Megginson <rmeggins@redhat.com>2009-09-21 10:28:50 -0600
commitcc89083f1177606d4cbbb52f8cdc5e34d0d16f70 (patch)
tree2cfebaacc69bc8fe416938b4bf9fbb51c73725eb /Makefile.am
parent2de80f5fb3398045dc7a25f5d25dfd7dd30c8909 (diff)
downloadds-cc89083f1177606d4cbbb52f8cdc5e34d0d16f70.tar.gz
ds-cc89083f1177606d4cbbb52f8cdc5e34d0d16f70.tar.xz
ds-cc89083f1177606d4cbbb52f8cdc5e34d0d16f70.zip
Add update code - make setup-ds.pl -u do updates
Updates are implemented in: perl - code that plugs in to setup - scriptlets that are imported into the setup perl interpreter and executed in process, giving access to all of the packages and context provided by setup ldif - applied to instances, in the same manner as ConfigFile directives to setup other - any executable file, shell script, etc. can be invoked, with a limited amount of context from the setup process An update directory is added to the package - /usr/share/dirsrv/update - this directory contains the update files - the update filenames begin with two digits and are executed in numeric order (00 first, then 01, etc. up to 99) which should provide enough flexibility In addition, there are 5 stages of update: pre - invoked before any instance specific code preinst, runinst, postinst - invoked for each instance post - invoked after any instance specific code Example files are provided which demonstrate how to get the context. There are two different modes of operation for update: online - must supply a bind dn and password for each instance - servers must be up and running offline - operates directly on the dse.ldif - servers must be shutdown first A new section is added to the .inf file that can be passed in [slapd-instancename] RootDN = binddn RootDNPwd = bindpw The RootDN is optional - if not supplied, it will get the nsslapd-rootdn attribute from the dse.ldif for the instance. I also fixed some problems with error messages. The pam pta plugin entry was giving object class violations, so I added the missing attributes - note that these are replaced by the plugin code when the plugin is loaded - they are only needed during setup. Fixed usage of $_ - $_ behaves like a dynamically scoped variable - which means if you use it in an outer context, you cannot use it in an inner context, even if it is used in a different function. Rather than attempting to figure out how to use $_ safely in lower level functions, I just removed the use of it altogether, which also makes the code easier to read. Reviewed by: nhosoi (Thanks!) - fixed minor issues found Platforms tested: Fedora 11
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am51
1 files changed, 48 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f35c6a2..49c345f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,6 +69,7 @@ CLEANFILES = dberrstrs.h ns-slapd.properties \
ldap/admin/src/scripts/template-dbverify ldap/admin/src/template-initconfig \
ldap/admin/src/scripts/dscreate.map ldap/admin/src/scripts/remove-ds.pl \
ldap/admin/src/scripts/DSCreate.pm ldap/admin/src/scripts/DSMigration.pm \
+ ldap/admin/src/scripts/DSUpdate.pm ldap/admin/src/scripts/dsupdate.map \
ldap/admin/src/scripts/dsorgentries.map ldap/admin/src/scripts/migrate-ds.pl \
ldap/admin/src/scripts/Migration.pm ldap/admin/src/scripts/SetupDialogs.pm \
ldap/admin/src/scripts/setup-ds.pl ldap/admin/src/scripts/setup-ds.res \
@@ -128,6 +129,7 @@ perldir = $(libdir)@perldir@
infdir = $(datadir)@infdir@
mibdir = $(datadir)@mibdir@
policydir = $(datadir)/selinux/targeted
+updatedir = $(datadir)@updatedir@
defaultuser=@defaultuser@
defaultgroup=@defaultgroup@
@@ -308,7 +310,9 @@ perl_DATA = ldap/admin/src/scripts/SetupLog.pm \
ldap/admin/src/scripts/Migration.pm \
ldap/admin/src/scripts/DSMigration.pm \
ldap/admin/src/scripts/FileConn.pm \
- ldap/admin/src/scripts/DSCreate.pm
+ ldap/admin/src/scripts/DSCreate.pm \
+ ldap/admin/src/scripts/DSUpdate.pm \
+ ldap/admin/src/scripts/DSUpdateDialogs.pm
property_DATA = ldap/admin/src/scripts/setup-ds.res \
ldap/admin/src/scripts/migrate-ds.res
@@ -351,6 +355,7 @@ initconfig_DATA = ldap/admin/src/$(PACKAGE_NAME)
inf_DATA = ldap/admin/src/slapd.inf \
ldap/admin/src/scripts/dscreate.map \
+ ldap/admin/src/scripts/dsupdate.map \
ldap/admin/src/scripts/dsorgentries.map
mib_DATA = ldap/servers/snmp/RFC-1215.txt \
@@ -383,6 +388,44 @@ dist_man_MANS = man/man1/dbscan.1 \
man/man8/setup-ds.pl.8 \
man/man8/remove-ds.pl.8
+#------------------------
+# updates
+# the first 3 are just the examples provided - since they
+# do not begin with two digits, they will be ignored
+# the remaining items should begin with two digits that
+# correspond to the order in which they should be applied
+# perl files and LDIF files are DATA - not executable
+# processed by the update script
+# shell scripts and other files are SCRIPTS - executable
+#------------------------
+update_DATA = ldap/admin/src/scripts/exampleupdate.pl \
+ ldap/admin/src/scripts/exampleupdate.ldif \
+ ldap/admin/src/scripts/50addchainingsaslpwroles.ldif \
+ ldap/admin/src/scripts/50memberofindex.ldif \
+ ldap/admin/src/scripts/50bitstringsyntaxplugin.ldif \
+ ldap/admin/src/scripts/50memberofplugin.ldif \
+ ldap/admin/src/scripts/50deliverymethodsyntaxplugin.ldif \
+ ldap/admin/src/scripts/50nameuidsyntaxplugin.ldif \
+ ldap/admin/src/scripts/50derefplugin.ldif \
+ ldap/admin/src/scripts/50numericstringsyntaxplugin.ldif \
+ ldap/admin/src/scripts/50disableurisyntaxplugin.ldif \
+ ldap/admin/src/scripts/50printablestringsyntaxplugin.ldif \
+ ldap/admin/src/scripts/50enhancedguidesyntaxplugin.ldif \
+ ldap/admin/src/scripts/50schemareloadplugin.ldif \
+ ldap/admin/src/scripts/50entryusnindex.ldif \
+ ldap/admin/src/scripts/50syntaxvalidplugin.ldif \
+ ldap/admin/src/scripts/50faxnumbersyntaxplugin.ldif \
+ ldap/admin/src/scripts/50teletexterminalidsyntaxplugin.ldif \
+ ldap/admin/src/scripts/50faxsyntaxplugin.ldif \
+ ldap/admin/src/scripts/50telexnumbersyntaxplugin.ldif \
+ ldap/admin/src/scripts/50guidesyntaxplugin.ldif \
+ ldap/admin/src/scripts/50linkedattrsplugin.ldif \
+ ldap/admin/src/scripts/50usnplugin.ldif \
+ ldap/admin/src/scripts/60upgradeschemafiles.pl \
+ ldap/admin/src/scripts/dnaplugindepends.ldif
+
+update_SCRIPTS = ldap/admin/src/scripts/exampleupdate.sh
+
#////////////////////////////////////////////////////////////////
#
# Server Strings
@@ -1251,7 +1294,8 @@ fixupcmd = sed \
-e 's,@with_fhs_opt\@,@with_fhs_opt@,g' \
-e 's,@with_selinux\@,@with_selinux@,g' \
-e 's,@perlexec\@,@perlexec@,g' \
- -e 's,@initconfigdir\@,$(initconfigdir),g'
+ -e 's,@initconfigdir\@,$(initconfigdir),g'\
+ -e 's,@updatedir\@,$(updatedir),g'
else
fixupcmd = sed \
-e 's,@bindir\@,$(bindir),g' \
@@ -1303,7 +1347,8 @@ fixupcmd = sed \
-e 's,@with_fhs_opt\@,@with_fhs_opt@,g' \
-e 's,@with_selinux\@,@with_selinux@,g' \
-e 's,@perlexec\@,@perlexec@,g' \
- -e 's,@initconfigdir\@,$(initconfigdir),g'
+ -e 's,@initconfigdir\@,$(initconfigdir),g' \
+ -e 's,@updatedir\@,$(updatedir),g'
endif
%: %.in