summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2009-11-12 11:20:16 -0700
committerRich Megginson <rmeggins@redhat.com>2009-11-16 11:48:40 -0700
commit2b2c26069aee6c0ead2c6ed95de5f181089025ac (patch)
tree201239e716a3621f76a0bd5351e0342df3751078 /Makefile.am
parent4c333c131975debacd65bdb5a96b7a56e9012048 (diff)
downloadds-2b2c26069aee6c0ead2c6ed95de5f181089025ac.tar.gz
ds-2b2c26069aee6c0ead2c6ed95de5f181089025ac.tar.xz
ds-2b2c26069aee6c0ead2c6ed95de5f181089025ac.zip
Implement support for versioning and release engineering procedures - version 1.2.5.a1389-ds-base-1.2.5.a1
Instead of changing configure.ac AC_INIT for each version change, there is a new file - VERSION.sh. This file also contains support for creating version numbers for pre-releases, and pre-release strings containing git commit hashes. One of the complications is that AC_INIT does not allow you to override the version and package tarname fields. We can override them after the fact everywhere except in config.h. AC_INIT defines the following which we would like to override but cannot: PACKAGE_VERSION PACKAGE_TARNAME PACKAGE_STRING PACKAGE_BUGREPORT Instead, we define DS_ versions of these e.g. DS_PACKAGE_VERSION etc. and make these available with AC_DEFINE(DS_PACKAGE_VERSION,...) etc. As an extra added precaution, we undefine these in Makefile.am like this: DS_DEFINES = ... \ -UPACKAGE_VERSION -UPACKAGE_TARNAME -UPACKAGE_STRING -UPACKAGE_BUGREPORT If someone tries to use PACKAGE_VERSION in C code, they will not be able to, and will have to use DS_PACKAGE_VERSION instead. All of the DS code that used PACKAGE_VERSION has been changed to use DS_PACKAGE_VERSION instead. There is a new make target - git-archive - as a convenience for creating source tarballs from git. By default, the source archive will be placed in the build directory - you can specify SRCDISTDIR=/path/to/SOURCES to use an alternate dir (e.g. make SRCDISTDIR=/path/to/rpmbuild/SOURCES git-archive to make a source tarball for rpmbuild) configure will print the branded package name and version Reviewed by: nkinder (Thanks!)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 676b5cf4..95eec142 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,9 @@ QUOTE := $(NULLSTRING)"# a double quote"
BUILDNUM := $(shell perl $(srcdir)/buildnum.pl)
NQBUILDNUM := $(subst \,,$(subst $(QUOTE),,$(BUILDNUM)))
DEBUG_DEFINES = @debug_defs@
-DS_DEFINES = -DBUILD_NUM=$(BUILDNUM) -DVENDOR="\"$(vendor)\"" -DBRAND="\"$(brand)\"" -DCAPBRAND="\"$(capbrand)\""
+# the -U undefines these symbols - should use the corresponding DS_ ones instead - see configure.ac
+DS_DEFINES = -DBUILD_NUM=$(BUILDNUM) -DVENDOR="\"$(vendor)\"" -DBRAND="\"$(brand)\"" -DCAPBRAND="\"$(capbrand)\"" \
+ -UPACKAGE_VERSION -UPACKAGE_TARNAME -UPACKAGE_STRING -UPACKAGE_BUGREPORT
DS_INCLUDES = -I$(srcdir)/ldap/include -I$(srcdir)/ldap/servers/slapd -I$(srcdir)/include -I.
# these paths are dependent on the settings of prefix and exec_prefix which may be specified
# at make time. So we cannot use AC_DEFINE in the configure.ac because that would set the
@@ -1367,3 +1369,18 @@ endif
if [ ! -d $(dir $@) ] ; then mkdir -p $(dir $@) ; fi
$(fixupcmd) $^ > $@
+# if distdir is a git tag, use that for the git archive tag, else
+# just assume a developer build and use HEAD
+git-archive:
+ if [ -n "$(SRCDISTDIR)" -a -d "$(SRCDISTDIR)" ] ; then \
+ srcdistdir=$(SRCDISTDIR) ; \
+ else \
+ srcdistdir=`pwd` ; \
+ fi ; \
+ cd $(srcdir) ; \
+ if git show-ref --tags -q $(distdir) ; then \
+ gittag=$(distdir) ; \
+ else \
+ gittag=HEAD ; \
+ fi ; \
+ git archive --prefix=$(distdir)/ $$gittag | bzip2 > $$srcdistdir/$(distdir).tar.bz2