summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Sommerseth <davids@redhat.com>2010-07-30 19:30:30 +0200
committerDavid Sommerseth <davids@redhat.com>2010-07-30 19:30:30 +0200
commite9aa46ab32a45bd7fc0ad32573d1db84f5049554 (patch)
treea736740bf5c38a84cf0f7868d97bfc02fdf5aaed /setup.py
parent1d4b0d894dd833cd9ac9e62cbdc400f24a11e32b (diff)
downloadpython-ethtool-e9aa46ab32a45bd7fc0ad32573d1db84f5049554.tar.gz
python-ethtool-e9aa46ab32a45bd7fc0ad32573d1db84f5049554.tar.xz
python-ethtool-e9aa46ab32a45bd7fc0ad32573d1db84f5049554.zip
Improved IPv6 support
As the IPv6 protocol allows a single device to have more than one IPv6 address, the previous implementation did not provide all IPv6 information. It would reject all except the last parsed IPv6 address. NOTE: This implementation will break the previous API. This change removes the ethtool.etherinfo.ipv6_address and ethtool.etherinfo.ipv6_netmask members. A new member is added, ethtool.etherinfo.ipv6_addresses (in plural). This contains a tupple list containing of ethtool.etherinfo_ipv6addr objects, one object for each configured IPv6 address on the device. These objects have the following members available: .address - The IPv6 address .netmask - The IPv6 netmask (in bit notation) .scope - A string with the IPv6 address scope Example code: import ethtool devs = ethtool.get_interfaces_info('eth0') for ip6 in devs[0].ipv6_addresses: print "[%s] %s/%i" % (ip6.scope, ip6.address, ip6.netmask) Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index aed2186..71b8c70 100644
--- a/setup.py
+++ b/setup.py
@@ -59,7 +59,8 @@ setup(name='ethtool',
sources = [
'python-ethtool/ethtool.c',
'python-ethtool/etherinfo.c',
- 'python-ethtool/etherinfo_obj.c'],
+ 'python-ethtool/etherinfo_obj.c',
+ 'python-ethtool/etherinfo_ipv6_obj.c'],
include_dirs = libnl['include'],
library_dirs = libnl['libdirs'],
libraries = libnl['libs']