summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Sommerseth <davids@redhat.com>2011-04-11 16:36:56 +0200
committerDavid Sommerseth <davids@redhat.com>2011-04-11 16:36:56 +0200
commit508ffffbb3c48eeeb11eeab2bf971180fe4e1940 (patch)
tree2b8133c62a904fd400f0cef0a3e2abb12048149a /setup.py
parentabc7f912f66d41dd734a10900429d4cad9377da5 (diff)
downloadpython-ethtool-508ffffbb3c48eeeb11eeab2bf971180fe4e1940.tar.gz
python-ethtool-508ffffbb3c48eeeb11eeab2bf971180fe4e1940.tar.xz
python-ethtool-508ffffbb3c48eeeb11eeab2bf971180fe4e1940.zip
Only open the NETLINK interface when needed
Do not open a NETLINK connection when loading the module, but rahter open it when needed. In a case where multiple users needs the connection, it will be shared and only closed when the last active user is done. Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index bde04dc..b8cbe9f 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ from distutils.core import setup, Extension
import commands
import sys
-version = '0.6'
+version = '0.7'
ethtool = Extension('ethtool',
sources = ['python-ethtool/ethtool.c',
@@ -53,8 +53,8 @@ libnl = pkgconfig('libnl-1')
setup(name='ethtool',
version=version,
description='Python module to interface with ethtool',
- author='Harald Hoyer & Arnaldo Carvalho de Melo',
- author_email='acme@redhat.com',
+ author='Harald Hoyer, Arnaldo Carvalho de Melo, David Sommerseth',
+ author_email='davids@redhat.com',
url='http://fedoraproject.org/wiki/python-ethtool',
ext_modules=[
Extension(