summaryrefslogtreecommitdiffstats
path: root/python-dmidecode.spec
diff options
context:
space:
mode:
authornima <nima@abc39116-655e-4be6-ad55-d661dc543056>2009-03-31 11:42:38 +0000
committernima <nima@abc39116-655e-4be6-ad55-d661dc543056>2009-03-31 11:42:38 +0000
commitd7200d96d5b90bcd0013c84ec1b053acbcca86c9 (patch)
tree76b63b8b927bdbb544fa2de66747baa5cd3da058 /python-dmidecode.spec
parent37d1a8117cd212ee9e47bbd4225ba76dece7dad7 (diff)
downloadpython-dmidecode-d7200d96d5b90bcd0013c84ec1b053acbcca86c9.tar.gz
python-dmidecode-d7200d96d5b90bcd0013c84ec1b053acbcca86c9.tar.xz
python-dmidecode-d7200d96d5b90bcd0013c84ec1b053acbcca86c9.zip
Reverting recent (pointless) change.
git-svn-id: svn://svn.autonomy.net.au/python-dmidecode@180 abc39116-655e-4be6-ad55-d661dc543056
Diffstat (limited to 'python-dmidecode.spec')
-rw-r--r--python-dmidecode.spec44
1 files changed, 44 insertions, 0 deletions
diff --git a/python-dmidecode.spec b/python-dmidecode.spec
new file mode 100644
index 0000000..bee613c
--- /dev/null
+++ b/python-dmidecode.spec
@@ -0,0 +1,44 @@
+%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+%{!?python_ver: %define python_ver %(%{__python} -c "import sys ; print sys.version[:3]")}
+
+Summary: python extension module to access DMI data
+Name: python-dmidecode
+Version: 2.10
+Release: 1
+License: GPLv3
+Group: System Environment/Libraries
+URL: http://projects.autonomy.net.au/dmidecode/
+Source0: %{name}-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+
+%description
+python-dmidecode is a python extension module that uses the
+code-base of the 'dmidecode' utility, and presents the data
+as python data structures
+
+%prep
+%setup -q
+
+%build
+make
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python src/setup.py install --root $RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%doc
+%{python_sitearch}/dmidecode.so
+%if "%{python_ver}" >= "2.5"
+%{python_sitearch}/*.egg-info
+%endif
+
+%changelog
+* Sat Mar 7 2009 Clark Williams <williams@redhat.com> - 2.10.3-1
+- Initial build.
+