summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authornima <nima@abc39116-655e-4be6-ad55-d661dc543056>2008-12-22 22:40:51 +0000
committernima <nima@abc39116-655e-4be6-ad55-d661dc543056>2008-12-22 22:40:51 +0000
commitd866a378dbc4645d224f06dfd41c5ca793690e81 (patch)
tree8a46dfb9640f3550fb01e94ff90e95c06df34091 /debian
parent25f310ab03c3010d89b0cafa989aeab94bcda58f (diff)
downloadpython-dmidecode-d866a378dbc4645d224f06dfd41c5ca793690e81.tar.gz
python-dmidecode-d866a378dbc4645d224f06dfd41c5ca793690e81.tar.xz
python-dmidecode-d866a378dbc4645d224f06dfd41c5ca793690e81.zip
Applied the nice changes suggested by Piotr Ożarowsk.
git-svn-id: svn://svn.autonomy.net.au/python-dmidecode@164 abc39116-655e-4be6-ad55-d661dc543056
Diffstat (limited to 'debian')
-rw-r--r--debian/control19
-rwxr-xr-xdebian/rules67
2 files changed, 51 insertions, 35 deletions
diff --git a/debian/control b/debian/control
index 2ab9e5a..a2feeb3 100644
--- a/debian/control
+++ b/debian/control
@@ -3,15 +3,15 @@ XS-Python-Version: >= 2.3
Section: python
Priority: optional
Maintainer: Nima Talebi <nima@it.net.au>
-Build-Depends: debhelper (>= 7), python-all-dev (>= 2.3.5-11), python-central (>= 0.6)
+Build-Depends: debhelper (>= 7), python-all-dev (>= 2.3.5-11), python-central (>= 0.6), python-all-dbg
Standards-Version: 3.8.0
Package: python-dmidecode
XB-Python-Version: ${python:Versions}
Architecture: any
Provides: ${python:Provides}
-Depends: ${python:Depends}, ${shlibs:Depends}
-Description: Python Extension Module for DMIDecode
+Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: Python extension module for dmidecode
DMI (the desktop management interface) provides a standardized description of
a computer's hardware, including characteristics such as BIOS serial number
and hardware connectors.
@@ -19,3 +19,16 @@ Description: Python Extension Module for DMIDecode
This package provides an interface to the DMI data available from the BIOS.
It is intended to be used as a back-end tool by other hardware detection
programs implemented in Python.
+
+Package: python-dmidecode-dbg
+Architecture: any
+Priority: extra
+Depends: python-dmidecode (= ${binary:Version}), python-dbg, ${shlibs:Depends}, ${misc:Depends}
+Provides: ${python:Provides}
+XB-Python-Version: ${python:Versions}
+Description: Python extension module for DMIDecode
+ DMI (the desktop management interface) provides a standardized description of
+ a computer's hardware, including characteristics such as BIOS serial number
+ and hardware connectors.
+ .
+ This package contains the extension built for the Python debug interpreter.
diff --git a/debian/rules b/debian/rules
index 5fcfc15..5874172 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,47 +1,43 @@
#!/usr/bin/make -f
#export DH_VERBOSE=1
-PYDEF = $(shell pyversions -d)
-PYVERS = $(shell pyversions -r)
+PYVERS = $(shell pyversions -vr)
-
-#############
-### Build ###
+################################################################################
+#. Build
build: build-stamp
-build-stamp: $(PYVERS:%=build-ext-%)
+build-stamp: $(PYVERS:%=build-ext-%) $(PYVERS:%=build-dbg-ext-%)
dh_testdir
- #docbook-to-man debian/python-dmidecode.sgml > python-dmidecode.1
- #$(MAKE) -f Makefile
touch $@
build-ext-%:
- $(subst $(PYDEF),python,$*) src/setup.py build
+ python$* src/setup.py build
+ touch $@
+build-dbg-ext-%:
+ python$*-dbg src/setup.py build
+ touch $@
-###############
-### Install ###
+################################################################################
+#. Install
install: install-stamp
dh_testdir
dh_testroot
dh_installdirs
- #$(MAKE) DESTDIR=$(CURDIR)/debian/python-dmidecode install
-install-stamp: build-stamp $(PYVERS:%=install-ext-%)
+install-stamp: build-stamp $(PYVERS:%=install-ext-%) $(PYVERS:%=install-dbg-ext-%)
install-ext-%:
- $(subst $(PYDEF),python,$*) src/setup.py install --root $(CURDIR)/debian/python-dmidecode
-
-
-#############
-### Clean ###
-clean:
- dh_testdir
- dh_testroot
- -rm -f build-stamp configure-stamp
- -rm -rf $(CURDIR)/debian/python-dmidecode
- $(MAKE) -f Makefile clean
- dh_clean
-
+ python$* src/setup.py install --root $(CURDIR)/debian/python-dmidecode
+ touch $@
+install-dbg-ext-%:
+ python$*-dbg src/setup.py install --root $(CURDIR)/debian/python-dmidecode-dbg
+ find $(CURDIR)/debian/python-dmidecode-dbg/usr/lib/python$*/ ! -type d ! -name '*_d\.so' -delete
+ find $(CURDIR)/debian/python-dmidecode-dbg/usr/lib/python$*/ -depth -empty -delete
+ touch $@
-binary-indep: build install
+################################################################################
+#. Binary
+binary: binary-indep binary-arch
+binary-indep:
binary-arch: build install
dh_testdir
dh_testroot
@@ -49,19 +45,26 @@ binary-arch: build install
dh_installdocs
dh_installexamples
dh_install
-# dh_python
-# dh_pysupport
dh_pycentral
dh_installman
dh_strip
dh_compress
dh_fixperms
-# dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+
+################################################################################
+#. Clean
+clean:
+ dh_testdir
+ dh_testroot
+ $(MAKE) -f Makefile clean
+ dh_clean build-stamp install-stamp \
+ $(PYVERS:%=install-ext-%) $(PYVERS:%=build-ext-%) \
+ $(PYVERS:%=install-dbg-ext-%) $(PYVERS:%=build-dbg-ext-%)
+
+.PHONY: build clean binary-indep binary-arch binary install