summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorNima Talebi <nima@epenguin1-3.appmgmt.det.nsw.edu.au>2009-04-14 19:08:51 +1000
committerNima Talebi <nima@epenguin1-3.appmgmt.det.nsw.edu.au>2009-04-14 19:08:51 +1000
commit7788d30989f2bafca2aacda198947c1841e420a3 (patch)
treece101115d87c1c32f0d14519fbab846d713f3c39 /debian
parent521af88003aef1af0118f2414c550e2762e4d94c (diff)
downloadpython-dmidecode-7788d30989f2bafca2aacda198947c1841e420a3.tar.gz
python-dmidecode-7788d30989f2bafca2aacda198947c1841e420a3.tar.xz
python-dmidecode-7788d30989f2bafca2aacda198947c1841e420a3.zip
Small cleanup change
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules9
2 files changed, 10 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 940a149..53d4551 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+python-dmidecode (2.10.5-2) unstable; urgency=low
+
+ * Minor cleanup.
+
+ -- Nima Talebi <nima@it.net.au> Tue, 14 Apr 2009 19:08:16 +1000
+
python-dmidecode (2.10.5-1) unstable; urgency=low
* Upstream (cleanup) release.
diff --git a/debian/rules b/debian/rules
index 5e4d832..641f65e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,12 +31,12 @@ install: install-stamp
dh_installman
install-stamp: build-stamp $(PYVERS:%=install-ext-%) $(PYVERS:%=install-dbg-ext-%)
install-ext-%:
- python$* src/setup.py install --root $(CURDIR)/debian/python-dmidecode
+ python$* src/setup.py install --root $(CURDIR)/debian/$(PACKAGE)
touch $@
install-dbg-ext-%:
- python$*-dbg src/setup-dbg.py install --root $(CURDIR)/debian/python-dmidecode-dbg
- #find $(CURDIR)/debian/python-dmidecode-dbg/usr/lib/python$*/ ! -type d ! -name '*_d\.so' -delete
- #find $(CURDIR)/debian/python-dmidecode-dbg/usr/lib/python$*/ -depth -empty -delete
+ python$*-dbg src/setup-dbg.py install --root $(CURDIR)/debian/$(PACKAGE)-dbg
+ #find $(CURDIR)/debian/$(PACKAGE)-dbg/usr/lib/python$*/ ! -type d ! -name '*_d\.so' -delete
+ #find $(CURDIR)/debian/$(PACKAGE)-dbg/usr/lib/python$*/ -depth -empty -delete
touch $@
################################################################################
@@ -62,7 +62,6 @@ clean:
dh_testdir
dh_testroot
$(MAKE) -f Makefile clean
- test $(CL_AGE) -le $(CACHE_AGE) || dh_clean
dh_clean build-stamp install-stamp \
$(PYVERS:%=install-ext-%) $(PYVERS:%=build-ext-%) \
$(PYVERS:%=install-dbg-ext-%) $(PYVERS:%=build-dbg-ext-%)