summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bbdd713..a6b3019 100644
--- a/configure.ac
+++ b/configure.ac
@@ -840,6 +840,10 @@ fi
dnl enable --x509-username-field feature if requested
if test "$X509ALTUSERNAME" = "yes"; then
+ if test "$SSL_LIB" = "polarssl" ; then
+ AC_MSG_ERROR([PolarSSL does not support the --x509-username-field feature])
+ fi
+
AC_DEFINE(ENABLE_X509ALTUSERNAME, 1, [Enable --x509-username-field feature])
fi