summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d217343..ef34697 100644
--- a/configure.ac
+++ b/configure.ac
@@ -886,7 +886,8 @@ fi
if test "${enable_pedantic}" = "yes"; then
enable_strict="yes"
- CFLAGS="${CFLAGS} -ansi -pedantic"
+ CFLAGS="${CFLAGS} -pedantic"
+ test "${WIN32}" != "yes" && CFLAGS="${CFLAGS} -ansi"
fi
if test "${enable_strict}" = "yes"; then
CFLAGS="${CFLAGS} -Wall -Wno-unused-parameter -Wno-unused-function"