summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrederic Crozat <fcrozat@suse.com>2011-10-31 15:51:53 +0100
committerDavid Sommerseth <davids@redhat.com>2012-01-09 16:59:51 +0100
commit9449e6a9eba30c9ed054f57d630a88c9f087080f (patch)
treede23332095cc8580e85263eb199cfcfca0a339e9 /configure.ac
parent6abb6cdd46e50b61452b1b2d3d796ab0061e9128 (diff)
downloadopenvpn-9449e6a9eba30c9ed054f57d630a88c9f087080f.tar.gz
openvpn-9449e6a9eba30c9ed054f57d630a88c9f087080f.tar.xz
openvpn-9449e6a9eba30c9ed054f57d630a88c9f087080f.zip
Add support to forward console query to systemd
Systemd requires console query to be forwarded using its own tool. Signed-off-by: Frederic Crozat <fcrozat@suse.com> Acked-by: David Sommerseth <davids@redhat.com> URL: http://thread.gmane.org/gmane.network.openvpn.devel/5073/focus=5277 Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a4d68e6..7143cc5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,6 +223,12 @@ AC_ARG_ENABLE(selinux,
[SELINUX="yes"]
)
+AC_ARG_ENABLE(systemd,
+ [ --enable-systemd Enable systemd suppport],
+ [SYSTEMD="$enableval"],
+ [SYSTEMD="no"]
+)
+
AC_ARG_WITH(ssl-headers,
[ --with-ssl-headers=DIR Crypto/SSL Include files location],
[CS_HDR_DIR="$withval"]
@@ -930,6 +936,11 @@ if test "$PASSWORD_SAVE" = "yes"; then
AC_DEFINE(ENABLE_PASSWORD_SAVE, 1, [Allow --askpass and --auth-user-pass passwords to be read from a file])
fi
+dnl enable systemd support
+if test "$SYSTEMD" = "yes"; then
+ AC_DEFINE(ENABLE_SYSTEMD, 1, [Enable systemd support])
+fi
+
dnl
dnl check for SELinux library and headers
dnl