summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGert Doering <gert@greenie.muc.de>2015-10-10 18:34:49 +0200
committerGert Doering <gert@greenie.muc.de>2015-10-11 10:25:06 +0200
commit9403e3f4b510fbc4187044f31be8f7dccbde1cf1 (patch)
treee4d0fe330a98c29b9ead343ec854891d849e3852 /configure.ac
parentc67acea173dc9ee37220f5b9ff14ede081181992 (diff)
downloadopenvpn-9403e3f4b510fbc4187044f31be8f7dccbde1cf1.tar.gz
openvpn-9403e3f4b510fbc4187044f31be8f7dccbde1cf1.tar.xz
openvpn-9403e3f4b510fbc4187044f31be8f7dccbde1cf1.zip
Remove support for snappy compression.
LZ4 is using less CPU at similar performance, and it is easier to build and support for binary installs (as it does not require C++ and a C++ runtime). Since it was never supported in any formally released OpenVPN version, just drop it again. This leaves in the compression opcode for Snappy for documentation purposes. trac #617 Signed-off-by: Gert Doering <gert@greenie.muc.de> Acked-by: Arne Schwabe <arne@rfc2549.org> Message-Id: <1444494889-28925-1-git-send-email-gert@greenie.muc.de> URL: http://article.gmane.org/gmane.network.openvpn.devel/10251
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 0 insertions, 48 deletions
diff --git a/configure.ac b/configure.ac
index 2e651d8..77b4915 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,12 +66,6 @@ AC_ARG_ENABLE(
[enable_lzo="yes"]
)
-AC_ARG_ENABLE(snappy,
- [ --disable-snappy Disable Snappy compression support],
- [enable_snappy="$enableval"],
- [enable_snappy="yes"]
-)
-
AC_ARG_ENABLE(lz4,
[ --disable-lz4 Disable LZ4 compression support],
[enable_lz4="$enableval"],
@@ -952,45 +946,6 @@ if test "${have_lzo}" = "yes"; then
fi
dnl
-dnl check for Snappy library
-dnl
-
-AC_ARG_VAR([SNAPPY_CFLAGS], [C compiler flags for snappy])
-AC_ARG_VAR([SNAPPY_LIBS], [linker flags for snappy])
-if test "$enable_snappy" = "yes" && test "$enable_comp_stub" = "no"; then
- AC_CHECKING([for Snappy Library and Header files])
- havesnappylib=1
-
- # if SNAPPY_LIBS is set, we assume it will work, otherwise test
- if test -z "${SNAPPY_LIBS}"; then
- AC_CHECK_LIB(snappy, snappy_compress,
- [ SNAPPY_LIBS="-lsnappy" ],
- [
- AC_MSG_RESULT([Snappy library not found.])
- havesnappylib=0
- ])
- fi
-
- saved_CFLAGS="${CFLAGS}"
- CFLAGS="${CFLAGS} ${SNAPPY_CFLAGS}"
- AC_CHECK_HEADERS(snappy-c.h,
- ,
- [
- AC_MSG_RESULT([Snappy headers not found.])
- havesnappylib=0
- ])
-
- if test $havesnappylib = 0 ; then
- AC_MSG_RESULT([Snappy library available from http://code.google.com/p/snappy/])
- AC_MSG_ERROR([Or try ./configure --disable-snappy OR ./configure --enable-comp-stub])
- fi
- OPTIONAL_SNAPPY_CFLAGS="${SNAPPY_CFLAGS}"
- OPTIONAL_SNAPPY_LIBS="${SNAPPY_LIBS}"
- AC_DEFINE(ENABLE_SNAPPY, 1, [Enable Snappy compression library])
- CFLAGS="${saved_CFLAGS}"
-fi
-
-dnl
dnl check for LZ4 library
dnl
@@ -1154,7 +1109,6 @@ if test "${enable_lzo}" = "yes"; then
fi
if test "${enable_comp_stub}" = "yes"; then
test "${enable_lzo}" = "yes" && AC_MSG_ERROR([Cannot have both comp stub and lzo enabled (use --disable-lzo)])
- test "${enable_snappy}" = "yes" && AC_MSG_ERROR([Cannot have both comp stub and snappy enabled (use --disable-snappy)])
test "${enable_lz4}" = "yes" && AC_MSG_ERROR([Cannot have both comp stub and LZ4 enabled (use --disable-lz4)])
AC_DEFINE([ENABLE_COMP_STUB], [1], [Enable compression stub capability])
fi
@@ -1220,8 +1174,6 @@ AC_SUBST([OPTIONAL_CRYPTO_CFLAGS])
AC_SUBST([OPTIONAL_CRYPTO_LIBS])
AC_SUBST([OPTIONAL_LZO_CFLAGS])
AC_SUBST([OPTIONAL_LZO_LIBS])
-AC_SUBST([OPTIONAL_SNAPPY_CFLAGS])
-AC_SUBST([OPTIONAL_SNAPPY_LIBS])
AC_SUBST([OPTIONAL_LZ4_CFLAGS])
AC_SUBST([OPTIONAL_LZ4_LIBS])
AC_SUBST([OPTIONAL_SYSTEMD_LIBS])