summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJosh Cepek <josh.cepek@usa.net>2013-11-14 12:02:59 -0600
committerGert Doering <gert@greenie.muc.de>2013-11-14 21:31:50 +0100
commit7fc9245f5d97c7d76c635f8a3e38ab55ab27b27b (patch)
tree1a4a2e22728809e1e4acaafcc7d2df5fd0aeaa74 /configure.ac
parent92d21e3fed33aad966b7b0ca6568e0cda8c7a8b5 (diff)
downloadopenvpn-7fc9245f5d97c7d76c635f8a3e38ab55ab27b27b.tar.gz
openvpn-7fc9245f5d97c7d76c635f8a3e38ab55ab27b27b.tar.xz
openvpn-7fc9245f5d97c7d76c635f8a3e38ab55ab27b27b.zip
Require a 1.2.x PolarSSL version
Upstream policy on PolarSSL API compatibility does not guarantee stability between point-releases. For OpenVPN, we must verify a 1.2.x version with the current codebase. This fixes bug#343. Signed-off-by: Josh Cepek <josh.cepek@usa.net> Acked-by: Steffan Karger <steffan.karger@fox-it.com> Message-Id: <5284F32D.3000206@usa.net> URL: http://article.gmane.org/gmane.network.openvpn.devel/7968 Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5fad0af..b181f6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -814,13 +814,13 @@ if test "${with_crypto_library}" = "polarssl" ; then
#include <polarssl/version.h>
]],
[[
-#if POLARSSL_VERSION_NUMBER < 0x01020A00
+#if POLARSSL_VERSION_NUMBER < 0x01020A00 || POLARSSL_VERSION_NUMBER >= 0x01030000
#error invalid version
#endif
]]
)],
[AC_MSG_RESULT([ok])],
- [AC_MSG_ERROR([PolarSSL 1.2.10 or newer required])]
+ [AC_MSG_ERROR([PolarSSL 1.2.x required and must be 1.2.10 or later])]
)
polarssl_with_pkcs11="no"