summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Bar-Lev <alon.barlev@gmail.com>2012-04-27 15:09:15 +0300
committerDavid Sommerseth <davids@redhat.com>2012-04-28 00:09:46 +0200
commit4029971240b6274b9b30e76ff74c7f689d7d9750 (patch)
tree02ee41e617185102cd9c79eae4e2dc172b4e863c /configure.ac
parent34091048af1ba94e8bf2049354610d16f8bb3d4c (diff)
downloadopenvpn-4029971240b6274b9b30e76ff74c7f689d7d9750.tar.gz
openvpn-4029971240b6274b9b30e76ff74c7f689d7d9750.tar.xz
openvpn-4029971240b6274b9b30e76ff74c7f689d7d9750.zip
build: use stdbool.h if available
If stdbool.h is available use it, otherwise create emulation. basic.h defines a type 'bool' that conflicts with the altivec keyword bool which has to be fixed upstream, see bugs[1][2]. [1] https://bugs.gentoo.org/show_bug.cgi?id=293840 [2] https://bugs.gentoo.org/show_bug.cgi?id=297854 Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com> Acked-by: David Sommerseth <davids@redhat.com> Message-Id: 1335528555-13225-1-git-send-email-alon.barlev@gmail.com URL: http://article.gmane.org/gmane.network.openvpn.devel/6363 Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5c9af30..82076af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -354,7 +354,7 @@ AX_EMPTY_ARRAY
AC_CHECK_SIZEOF([unsigned int])
AC_CHECK_SIZEOF([unsigned long])
AC_CHECK_HEADERS([ \
- stdio.h stdarg.h limits.h \
+ stdio.h stdarg.h stdbool.h limits.h \
time.h errno.h fcntl.h io.h direct.h \
ctype.h sys/types.h sys/socket.h \
signal.h unistd.h dlfcn.h \