summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Bar-Lev <alon.barlev@gmail.com>2012-05-21 14:04:14 +0300
committerDavid Sommerseth <davids@redhat.com>2012-06-01 12:52:29 +0200
commit13b38eb0a3e609a5f0f4f12e2578e68ff2ac0a22 (patch)
tree4aa7819ba1fd1030e329125ff5a80d04a4e1f4b2 /configure.ac
parent47c990009c79fe2a96206c54e0240cb2dd8cdf02 (diff)
downloadopenvpn-13b38eb0a3e609a5f0f4f12e2578e68ff2ac0a22.tar.gz
openvpn-13b38eb0a3e609a5f0f4f12e2578e68ff2ac0a22.tar.xz
openvpn-13b38eb0a3e609a5f0f4f12e2578e68ff2ac0a22.zip
build: check minimum polarssl version
Pre 1.1 is unsupported, API was changed. Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com> Reviewed-by: Adriaan de Jong <dejong@fox-it.com> Acked-by: David Sommerseth <davids@redhat.com> Message-Id: 1337598254-32641-1-git-send-email-alon.barlev@gmail.com URL: http://article.gmane.org/gmane.network.openvpn.devel/6613 Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 399b4e7..8d0a843 100644
--- a/configure.ac
+++ b/configure.ac
@@ -734,6 +734,27 @@ if test -z "${POLARSSL_LIBS}"; then
)
fi
+if test "${with_crypto_library}" = "polarssl" ; then
+ AC_MSG_CHECKING([polarssl version])
+ old_CFLAGS="${CFLAGS}"
+ CFLAGS="${POLARSSL_CFLAGS} ${CFLAGS}"
+ AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[
+#include <polarssl/version.h>
+ ]],
+ [[
+#if POLARSSL_VERSION_NUMBER <= 0x01010000
+#error invalid version
+#endif
+ ]]
+ )],
+ [AC_MSG_RESULT([ok])],
+ [AC_MSG_ERROR([invalid polarssl version])]
+ )
+ CFLAGS="${old_CFLAGS}"
+fi
+
AC_ARG_VAR([LZO_CFLAGS], [C compiler flags for lzo])
AC_ARG_VAR([LZO_LIBS], [linker flags for lzo])
have_lzo="yes"