summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Sommerseth <davids@redhat.com>2011-11-21 16:17:44 +0100
committerDavid Sommerseth <davids@redhat.com>2012-01-11 16:02:47 +0100
commit032f0045246846f566f7433e95376916beb980b0 (patch)
tree0c93384858a3d86ff4ee7d4abc8580a7b70e0755 /configure.ac
parentedf8bbacd18d063e50c6a7f787f7e413d146af87 (diff)
downloadopenvpn-032f0045246846f566f7433e95376916beb980b0.tar.gz
openvpn-032f0045246846f566f7433e95376916beb980b0.tar.xz
openvpn-032f0045246846f566f7433e95376916beb980b0.zip
Fix compilation errors on Linux platforms without SO_MARK
When trying to compile OpenVPN on RHEL5/CentOS5, it would fail due to missing declaration of SO_MARK. SO_MARK is a feature which first arrived in 2.6.26, and was never backported to RHEL5's 2.6.18 kernel base. This patch adds a check at configure time, to see if SO_MARK is available or not. Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f904db4..19173e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -443,6 +443,9 @@ if test "${WIN32}" != "yes"; then
# include <linux/types.h>
#endif
])
+
+ dnl Check if SO_MARK is available
+ AC_TRY_COMPILE([#include <sys/socket.h>], [if( SO_MARK > 0) return 1;], [AC_DEFINE(HAVE_SO_MARK,[],[Is SO_MARK available?])])
fi
AC_CACHE_SAVE