summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2010-04-08 20:31:01 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-04-08 20:31:01 +0200
commitf27bf509315a48b0070294c3993a718df0c2626c (patch)
tree09fcb800b0a3f995694c30539ed157d5290d5c28 /Makefile.am
parent9f4725e86be9700c5894e360e09496d9ee1cfb85 (diff)
downloadopenvpn-f27bf509315a48b0070294c3993a718df0c2626c.tar.gz
openvpn-f27bf509315a48b0070294c3993a718df0c2626c.tar.xz
openvpn-f27bf509315a48b0070294c3993a718df0c2626c.zip
Add comile time information/settings from ./configure to --version
This patch will create ./configure.h which will contain two new #define strings. CONFIGURE_DEFINES will contain all USE, ENABLED, DISABLED and DEPRECATED defines from ./config.h. CONFIGURE_CALL will contain the complete ./configure line which was used when configuring the package for building. Signed-off-by: David Sommerseth <dazo@users.sourceforge.net> Acked-by: James Yonan <james@openvpn.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7bccc11..20453d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,7 @@
# packet compression.
#
# Copyright (C) 2002-2009 OpenVPN Technologies, Inc. <sales@openvpn.net>
+# Copyright (C) 2010 David Sommerseth <dazo@users.sourceforge.net>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2
@@ -140,6 +141,12 @@ openvpn_SOURCES = \
win32.h win32.c \
cryptoapi.h cryptoapi.c
+configure.h: Makefile
+ awk -f configure_h.awk config.h > $@
+ awk -f configure_log.awk config.log >> $@
+
+clean-local:
+ -rm -f configure.h
dist-hook:
cd $(distdir) && for i in $(EXTRA_DIST) $(SUBDIRS) ; do find $$i -name .svn -type d -prune -exec rm -rf '{}' ';' ; rm -f `find $$i -type f | grep -E '(^|\/)\.?\#|\~$$|\.s?o$$'` ; done