summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2010-04-08 20:31:01 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-10-21 21:18:17 +0200
commitd94049b8284cdddd90fc17cc171fbf20fcc12780 (patch)
treee59cda28bcfeb88504d15cb0f80b9454922f4d49 /Makefile.am
parent6dc60191ddf8673db7d156e6b90fb794e4fa350a (diff)
downloadopenvpn-d94049b8284cdddd90fc17cc171fbf20fcc12780.tar.gz
openvpn-d94049b8284cdddd90fc17cc171fbf20fcc12780.tar.xz
openvpn-d94049b8284cdddd90fc17cc171fbf20fcc12780.zip
Add comile time information/settings from ./configure to --version
This patch will create ./configure.h which will contain two new #define strings. CONFIGURE_DEFINES will contain all USE, ENABLED, DISABLED and DEPRECATED defines from ./config.h. CONFIGURE_CALL will contain the complete ./configure line which was used when configuring the package for building. Signed-off-by: David Sommerseth <dazo@users.sourceforge.net> Acked-by: James Yonan <james@openvpn.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ad0f7e3..3b858e2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,7 @@
# packet compression.
#
# Copyright (C) 2002-2010 OpenVPN Technologies, Inc. <sales@openvpn.net>
+# Copyright (C) 2010 David Sommerseth <dazo@users.sourceforge.net>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2
@@ -141,6 +142,12 @@ openvpn_SOURCES = \
win32.h win32.c \
cryptoapi.h cryptoapi.c
+configure.h: Makefile
+ awk -f configure_h.awk config.h > $@
+ awk -f configure_log.awk config.log >> $@
+
+clean-local:
+ -rm -f configure.h
dist-hook:
cd $(distdir) && for i in $(EXTRA_DIST) $(SUBDIRS) ; do find $$i -name .svn -type d -prune -exec rm -rf '{}' ';' ; rm -f `find $$i -type f | grep -E '(^|\/)\.?\#|\~$$|\.s?o$$'` ; done