summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlon Bar-Lev <alon.barlev@gmail.com>2012-02-29 22:11:56 +0200
committerDavid Sommerseth <davids@redhat.com>2012-03-22 22:07:07 +0100
commit51bd56f46f55177cf0f8b7811b35a009e150d55e (patch)
tree1a5a94057b01d0dd22c9715123e8d6bf0b988052 /Makefile.am
parent0dbd45db7d76fdff9fbaa64d147c2d2278492efc (diff)
downloadopenvpn-51bd56f46f55177cf0f8b7811b35a009e150d55e.tar.gz
openvpn-51bd56f46f55177cf0f8b7811b35a009e150d55e.tar.xz
openvpn-51bd56f46f55177cf0f8b7811b35a009e150d55e.zip
build: autotools: first pass of trivial autotools changes
Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com> Acked-by: Adriaan de Jong <dejong@fox-it.com> Acked-by: David Sommerseth <davids@redhat.com> Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 14 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b883da..6c0b2b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,11 +23,9 @@
# 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
-LDADD = @LIBOBJS@
-
# This option prevents autoreconf from overriding our COPYING and
# INSTALL targets:
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.9
ACLOCAL_AMFLAGS = -I m4
MAINTAINERCLEANFILES = \
@@ -62,11 +60,22 @@ dist_noinst_SCRIPTS = \
t_cltsrv-down.sh \
configure_h.awk configure_log.awk
+dist_doc_DATA = \
+ COPYRIGHT.GPL \
+ COPYING
+
dist_noinst_DATA = \
+ .gitignore \
openvpn.spec \
- COPYRIGHT.GPL \
PORTS \
- INSTALL-win32.txt
+ README.IPv6 TODO.IPv6 \
+ README.polarssl \
+
+if WIN32
+dist_doc_DATA += INSTALL-win32.txt
+else
+dist_noinst_DATA += INSTALL-win32.txt
+endif
openvpn_SOURCES = \
base64.c base64.h \
@@ -154,9 +163,6 @@ configure.h: Makefile
awk -f $(srcdir)/configure_h.awk config.h > $@
awk -f $(srcdir)/configure_log.awk config.log >> $@
-dist-hook:
- cd $(distdir) && for i in $(EXTRA_DIST) $(SUBDIRS) ; do find $$i -name .svn -type d -prune -exec rm -rf '{}' ';' ; rm -f `find $$i -type f | grep -E '(^|\/)\.?\#|\~$$|\.s?o$$'` ; done
-
if WIN32
dist_noinst_DATA += openvpn.8
nodist_html_DATA = openvpn.8.html