summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlon Bar-Lev <alon.barlev@gmail.com>2012-02-29 22:11:59 +0200
committerDavid Sommerseth <davids@redhat.com>2012-03-22 22:07:08 +0100
commit34cb9132ef2dae08f91a66015ea5437539a4b557 (patch)
treeedd69bb83cc490a47692cb847d066231cd6146fd /Makefile.am
parentfcff80aac1f71ebf881fbc269fb3c4df0789de6b (diff)
downloadopenvpn-34cb9132ef2dae08f91a66015ea5437539a4b557.tar.gz
openvpn-34cb9132ef2dae08f91a66015ea5437539a4b557.tar.xz
openvpn-34cb9132ef2dae08f91a66015ea5437539a4b557.zip
build: standard directory layout
Suitable for mature project. root - administrative stuff doc - documents src - sources tests - tests distro - distro specific files sample - samples SIDE EFFECT: many changes to rpm spec. Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com> Acked-by: Adriaan de Jong <dejong@fox-it.com> Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am115
1 files changed, 5 insertions, 110 deletions
diff --git a/Makefile.am b/Makefile.am
index a8ff457..850074b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,7 @@
#
# Copyright (C) 2002-2010 OpenVPN Technologies, Inc. <sales@openvpn.net>
# Copyright (C) 2010 David Sommerseth <dazo@users.sourceforge.net>
+# Copyright (C) 2006-2012 Alon Bar-Lev <alon.barlev@gmail.com>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2
@@ -34,30 +35,13 @@ MAINTAINERCLEANFILES = \
$(srcdir)/config.h.in $(srcdir)/config.h.in~ $(srcdir)/configure \
$(srcdir)/install-sh $(srcdir)/ltmain.sh $(srcdir)/missing \
$(srcdir)/depcomp $(srcdir)/aclocal.m4 \
- $(srcdir)/config.guess $(srcdir)/config.sub \
- $(srcdir)/openvpn.spec
-CLEANFILES = openvpn.8.html
+ $(srcdir)/config.guess $(srcdir)/config.sub
EXTRA_DIST = \
- sample-config-files \
- sample-keys \
- sample-scripts \
- suse \
contrib \
- debug \
- plugins
+ debug
-SUBDIRS = service-win32
-
-TESTS = t_client.sh t_lpback.sh t_cltsrv.sh
-sbin_PROGRAMS = openvpn
-
-dist_doc_DATA = \
- management/management-notes.txt
-
-dist_noinst_SCRIPTS = \
- $(TESTS) \
- t_cltsrv-down.sh
+SUBDIRS = distro include src sample doc tests
dist_doc_DATA = \
COPYRIGHT.GPL \
@@ -65,101 +49,12 @@ dist_doc_DATA = \
dist_noinst_DATA = \
.gitignore \
- openvpn.spec \
PORTS \
README.IPv6 TODO.IPv6 \
- README.polarssl \
+ README.polarssl
if WIN32
dist_doc_DATA += INSTALL-win32.txt
else
dist_noinst_DATA += INSTALL-win32.txt
endif
-
-openvpn_SOURCES = \
- base64.c base64.h \
- basic.h \
- buffer.c buffer.h \
- circ_list.h \
- clinat.c clinat.h \
- common.h \
- compat.h compat.c \
- crypto.c crypto.h crypto_backend.h \
- crypto_openssl.c crypto_openssl.h \
- crypto_polarssl.c crypto_polarssl.h \
- dhcp.c dhcp.h \
- errlevel.h \
- error.c error.h \
- event.c event.h \
- fdmisc.c fdmisc.h \
- forward.c forward.h forward-inline.h \
- fragment.c fragment.h \
- gremlin.c gremlin.h \
- helper.c helper.h \
- httpdigest.c httpdigest.h \
- lladdr.c lladdr.h \
- init.c init.h \
- integer.h \
- interval.c interval.h \
- list.c list.h \
- lzo.c lzo.h \
- manage.c manage.h \
- mbuf.c mbuf.h \
- memdbg.h \
- misc.c misc.h \
- mroute.c mroute.h \
- mss.c mss.h \
- mstats.c mstats.h \
- mtcp.c mtcp.h \
- mtu.c mtu.h \
- mudp.c mudp.h \
- multi.c multi.h \
- ntlm.c ntlm.h \
- occ.c occ.h occ-inline.h \
- pkcs11.c pkcs11.h pkcs11_backend.h \
- pkcs11_openssl.c \
- pkcs11_polarssl.c \
- openvpn.c openvpn.h \
- openvpn-plugin.h \
- options.c options.h \
- otime.c otime.h \
- packet_id.c packet_id.h \
- perf.c perf.h \
- pf.c pf.h pf-inline.h \
- ping.c ping.h ping-inline.h \
- plugin.c plugin.h \
- pool.c pool.h \
- proto.c proto.h \
- proxy.c proxy.h \
- ps.c ps.h \
- push.c push.h \
- pushlist.h \
- reliable.c reliable.h \
- route.c route.h \
- schedule.c schedule.h \
- session_id.c session_id.h \
- shaper.c shaper.h \
- sig.c sig.h \
- socket.c socket.h \
- socks.c socks.h \
- ssl.c ssl.h ssl_backend.h \
- ssl_openssl.c ssl_openssl.h \
- ssl_polarssl.c ssl_polarssl.h \
- ssl_common.h \
- ssl_verify.c ssl_verify.h ssl_verify_backend.h \
- ssl_verify_openssl.c ssl_verify_openssl.h \
- ssl_verify_polarssl.c ssl_verify_polarssl.h \
- status.c status.h \
- syshead.h \
- tun.c tun.h tap-windows.h \
- win32.h win32.c \
- cryptoapi.h cryptoapi.c
-
-if WIN32
-dist_noinst_DATA += openvpn.8
-nodist_html_DATA = openvpn.8.html
-openvpn.8.html: $(srcdir)/openvpn.8
- $(MAN2HTML) < $(srcdir)/openvpn.8 > openvpn.8.html
-else
-dist_man_MANS = openvpn.8
-endif