summaryrefslogtreecommitdiffstats
path: root/rpm/SPECS
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2013-12-25 20:38:04 +0100
committerDavid Sommerseth <dazo@users.sourceforge.net>2013-12-26 00:22:32 +0100
commit8655f934aabe1ba64668cb9dfff6e3e65e79083a (patch)
tree539918a7b717fc06abf227b53c5c5e8b3195d4ba /rpm/SPECS
parentfe5af5506200b6bf09ff355460b7c1bd317a1b95 (diff)
downloadlogactio-8655f934aabe1ba64668cb9dfff6e3e65e79083a.tar.gz
logactio-8655f934aabe1ba64668cb9dfff6e3e65e79083a.tar.xz
logactio-8655f934aabe1ba64668cb9dfff6e3e65e79083a.zip
Initial RPM packaging
Signed-off-by: David Sommerseth <dazo@users.sourceforge.net>
Diffstat (limited to 'rpm/SPECS')
-rw-r--r--rpm/SPECS/logactio.spec47
1 files changed, 47 insertions, 0 deletions
diff --git a/rpm/SPECS/logactio.spec b/rpm/SPECS/logactio.spec
new file mode 100644
index 0000000..68829c9
--- /dev/null
+++ b/rpm/SPECS/logactio.spec
@@ -0,0 +1,47 @@
+%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+%{!?python_ver: %define python_ver %(%{__python} -c "import sys ; print sys.version[:3]")}
+
+Summary: A simple log tracker which acts on certain events
+Name: logactio
+Version: 0.01
+Release: 1
+License: GPLv2
+Group: System Environment/Daemons
+URL: http://fedorapeople.org/cgit/dsommers/public_git/logactio.git/
+Source0: %{name}-%{version}.tar.bz2
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+
+%description
+LogActio is a modular log tracker, which observes changes and acts
+through different modules based on the event. It is purely written
+in Python and can easily be extended with specific actions.
+
+%prep
+%setup -q
+
+%build
+%{__python} setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install --root=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%doc COPYING
+%{_bindir}/logactio
+%{python_sitelib}/LogActio
+
+%if "%{python_ver}" >= "2.5"
+%{python_sitelib}/*.egg-info
+%endif
+
+%changelog
+* Wed Dec 25 2013 David Sommerseth <dazo@users.sourceforge.net> - 0.01-1
+- Initial RPM packaging
+