summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..ab013c0
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+PROJECT(eurephia C)
+cmake_minimum_required(VERSION 2.6)
+SET(eurephia_auth_SRC
+ certinfo.c
+ eurephia-auth.c
+ eurephia.c
+ eurephiadb.c
+ eurephiadb_session.c
+ eurephiafw.c
+ eurephiafw_helpers.c
+ eurephia_getsym.c
+ eurephia_log.c
+ eurephia_values.c
+ passwd.c
+ sha512.c
+)
+INCLUDE_DIRECTORIES(BEFORE ../../openvpn/openvpn-2.1_rc7 .)
+ADD_LIBRARY(eurephia-auth MODULE ${eurephia_auth_SRC})
+SET_TARGET_PROPERTIES(eurephia-auth PROPERTIES OUTPUT_NAME eurephia-auth PREFIX "")
+SUBDIRS(database/sqlite firewall/iptables)
+