summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-10-02 17:52:09 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-10-02 17:52:09 +0200
commit1a331308273fcd2a2a08c0734f05dee9bad1f6ef (patch)
tree2599af6007d44c42e1d59d03de583de840af9f7e /CMakeLists.txt
parent62b23e6d98353f4093d42bd3cdf14e826bbd4055 (diff)
downloadeurephia-1a331308273fcd2a2a08c0734f05dee9bad1f6ef.tar.gz
eurephia-1a331308273fcd2a2a08c0734f05dee9bad1f6ef.tar.xz
eurephia-1a331308273fcd2a2a08c0734f05dee9bad1f6ef.zip
Added support for cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..ab013c0
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+PROJECT(eurephia C)
+cmake_minimum_required(VERSION 2.6)
+SET(eurephia_auth_SRC
+ certinfo.c
+ eurephia-auth.c
+ eurephia.c
+ eurephiadb.c
+ eurephiadb_session.c
+ eurephiafw.c
+ eurephiafw_helpers.c
+ eurephia_getsym.c
+ eurephia_log.c
+ eurephia_values.c
+ passwd.c
+ sha512.c
+)
+INCLUDE_DIRECTORIES(BEFORE ../../openvpn/openvpn-2.1_rc7 .)
+ADD_LIBRARY(eurephia-auth MODULE ${eurephia_auth_SRC})
+SET_TARGET_PROPERTIES(eurephia-auth PROPERTIES OUTPUT_NAME eurephia-auth PREFIX "")
+SUBDIRS(database/sqlite firewall/iptables)
+