summaryrefslogtreecommitdiffstats
path: root/plugin/firewall/iptables/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2009-04-11 00:31:48 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2009-04-11 00:31:48 +0200
commit75f1e6f6b12f9fe461e4afa5bf3c998d21d48394 (patch)
tree77420f3134189dc5bce5b0d3fe77826b66f702aa /plugin/firewall/iptables/CMakeLists.txt
parent10fd2098416c78958a199f31480bd363eaa76212 (diff)
downloadeurephia-75f1e6f6b12f9fe461e4afa5bf3c998d21d48394.tar.gz
eurephia-75f1e6f6b12f9fe461e4afa5bf3c998d21d48394.tar.xz
eurephia-75f1e6f6b12f9fe461e4afa5bf3c998d21d48394.zip
Rewritten CMake rules to build common/ as static library
This static library is later on linked in. This is to avoid recompiling the same source files several times during a complete eurephia compilation.
Diffstat (limited to 'plugin/firewall/iptables/CMakeLists.txt')
-rw-r--r--plugin/firewall/iptables/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/plugin/firewall/iptables/CMakeLists.txt b/plugin/firewall/iptables/CMakeLists.txt
index 69173d7..789a237 100644
--- a/plugin/firewall/iptables/CMakeLists.txt
+++ b/plugin/firewall/iptables/CMakeLists.txt
@@ -3,11 +3,10 @@ cmake_minimum_required(VERSION 2.6)
SET(efw_ipt_SRC
efw-iptables.c
../eurephiafw_helpers.c
- ../../../common/eurephia_log.c
)
INCLUDE_DIRECTORIES(BEFORE ../..)
ADD_LIBRARY(efw-iptables MODULE ${efw_ipt_SRC})
-TARGET_LINK_LIBRARIES(efw-iptables pthread rt gcc_s)
+TARGET_LINK_LIBRARIES(efw-iptables pthread rt gcc_s common)
SET_TARGET_PROPERTIES(efw-iptables PROPERTIES PREFIX "")
INSTALL(TARGETS efw-iptables LIBRARY DESTINATION ${PLUGINDIR})