summaryrefslogtreecommitdiffstats
path: root/plugin/firewall/iptables/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-10-15 00:39:53 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-10-15 00:39:53 +0200
commit0ea1a3e2e6a10300388e01ac89504abe3624ae56 (patch)
treefff59c70d4db431c2114e89d0819af8921aff463 /plugin/firewall/iptables/CMakeLists.txt
parentb65b0802ead5e863ca8cb41fff77528735a1466c (diff)
downloadeurephia-0ea1a3e2e6a10300388e01ac89504abe3624ae56.tar.gz
eurephia-0ea1a3e2e6a10300388e01ac89504abe3624ae56.tar.xz
eurephia-0ea1a3e2e6a10300388e01ac89504abe3624ae56.zip
Reorganised the source code
Moved all OpenVPN plug-in related things into ./plugins, including firewall Moved all shared code into ./common and moved the generic part of the database files into ./database Updated all CMakeLists.txt files and created a new one for the root directory
Diffstat (limited to 'plugin/firewall/iptables/CMakeLists.txt')
-rw-r--r--plugin/firewall/iptables/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/plugin/firewall/iptables/CMakeLists.txt b/plugin/firewall/iptables/CMakeLists.txt
new file mode 100644
index 0000000..0f77a1b
--- /dev/null
+++ b/plugin/firewall/iptables/CMakeLists.txt
@@ -0,0 +1,12 @@
+PROJECT(eurephiafw-iptables C)
+cmake_minimum_required(VERSION 2.6)
+SET(efw_ipt_SRC
+ efw_iptables.c
+ ../eurephiafw_helpers.c
+ ../../../common/eurephia_log.c
+)
+
+INCLUDE_DIRECTORIES(BEFORE ../..)
+ADD_LIBRARY(efw_iptables MODULE ${efw_ipt_SRC})
+TARGET_LINK_LIBRARIES(efw_iptables pthread rt gcc_s)
+SET_TARGET_PROPERTIES(efw_iptables PROPERTIES PREFIX "")