summaryrefslogtreecommitdiffstats
path: root/eurephiadm/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2009-03-29 18:47:10 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2009-03-29 18:47:10 +0200
commitd7a8babb19bcc1107daff0cc5673bc32b0ed785b (patch)
tree19d0c05f05d533ab39e9f95b96f5b96d8aa3afac /eurephiadm/CMakeLists.txt
parent0c7c0c7ea6e61872dafd3a7a49a10f63b819693c (diff)
downloadeurephia-d7a8babb19bcc1107daff0cc5673bc32b0ed785b.tar.gz
eurephia-d7a8babb19bcc1107daff0cc5673bc32b0ed785b.tar.xz
eurephia-d7a8babb19bcc1107daff0cc5673bc32b0ed785b.zip
Prepared for linking in libxslt
Added two extra ./configure arguments, --xslt-path which defines the root directory for all eurephia specific XSLT templates (defaults to /usr/share/eurephia/xslt) and --eurephiadm-xslt which defines the path eurephiadm will use for its XSLT templates (defaults to /usr/share/eurephia/xslt/eurephiadm) Added an extra configuration paramet for eurephiadm (eurephiadm_xslt_path), which can be used to override the compiled in default values
Diffstat (limited to 'eurephiadm/CMakeLists.txt')
-rw-r--r--eurephiadm/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/eurephiadm/CMakeLists.txt b/eurephiadm/CMakeLists.txt
index b6922cb..0e40aa9 100644
--- a/eurephiadm/CMakeLists.txt
+++ b/eurephiadm/CMakeLists.txt
@@ -32,6 +32,10 @@ IF(FIREWALL)
ENDIF(FIREWALL)
+
+SET(EUREPHIADM_XSLT_PATH "${XSLTROOT}/eurephiadm/" CACHE STRING "Path for eurephiadm XSLT templates")
+ADD_DEFINITIONS(-DEUREPHIADM_XSLT_PATH="${EUREPHIADM_XSLT_PATH}")
+
INCLUDE_DIRECTORIES(../common ../database)
ADD_EXECUTABLE(eurephiadm ${efw_ipt_SRC})
TARGET_LINK_LIBRARIES(eurephiadm dl crypto ${EXTRA_LIBS})