summaryrefslogtreecommitdiffstats
path: root/eurephiadm/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-12-11 00:05:29 +0100
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-12-11 00:05:29 +0100
commit94b035d4a269bf79374d8b43281cb516e5218a6c (patch)
tree1e9d1f6cf3b29f0d0210eec33d496098edbfe712 /eurephiadm/CMakeLists.txt
parentc71f6dab57b454f19f3566b6ed544ff10342ec16 (diff)
downloadeurephia-94b035d4a269bf79374d8b43281cb516e5218a6c.tar.gz
eurephia-94b035d4a269bf79374d8b43281cb516e5218a6c.tar.xz
eurephia-94b035d4a269bf79374d8b43281cb516e5218a6c.zip
Added functions for processing eurephiaACCESSINFO/eurephiaACCESSLIST
Implemented saving VPN access profile to the eurephiaCERTINFO struct and filling the eurephiaACCESSINFO with the proper information needed in the eDBadminGetUserInfo(...) function. The special thing about eurephiaACCESSINFO, is that it will not register duplicate records. And when the eurephiaCERTINFO is free'd, the eurephiaACCESSLIST will automatically be free'd as well.
Diffstat (limited to 'eurephiadm/CMakeLists.txt')
-rw-r--r--eurephiadm/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/eurephiadm/CMakeLists.txt b/eurephiadm/CMakeLists.txt
index a920ac6..be23c15 100644
--- a/eurephiadm/CMakeLists.txt
+++ b/eurephiadm/CMakeLists.txt
@@ -20,6 +20,11 @@ SET(efw_ipt_SRC
../database/eurephiadb.c
)
+IF(FIREWALL)
+ ADD_DEFINITIONS(-DFIREWALL)
+
+ENDIF(FIREWALL)
+
INCLUDE_DIRECTORIES(../common ../database)
ADD_EXECUTABLE(eurephiadm ${efw_ipt_SRC})
TARGET_LINK_LIBRARIES(eurephiadm dl crypto)