summaryrefslogtreecommitdiffstats
path: root/eurephia.spec
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2010-06-30 17:19:11 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-07-30 11:02:54 +0200
commit03efa7864efa30361c3868f9c477639110e6f424 (patch)
tree3febf40ed6a0c2dd352da1de4b8a5ca92721c9fb /eurephia.spec
parent430758cb6c263576ddcf3bcae27ed253df973daa (diff)
downloadeurephia-03efa7864efa30361c3868f9c477639110e6f424.tar.gz
eurephia-03efa7864efa30361c3868f9c477639110e6f424.tar.xz
eurephia-03efa7864efa30361c3868f9c477639110e6f424.zip
Updated eurephia.spec to be ready for the 1.0.0 release
Diffstat (limited to 'eurephia.spec')
-rw-r--r--eurephia.spec38
1 files changed, 20 insertions, 18 deletions
diff --git a/eurephia.spec b/eurephia.spec
index 51b64a6..8c3b172 100644
--- a/eurephia.spec
+++ b/eurephia.spec
@@ -1,8 +1,5 @@
-%define betatag beta
-%define ovpnver 2.1_rc21
-
Name: eurephia
-Version: 0.9.6
+Version: 1.0.0
Release: 1%{?betatag:.%{betatag}}%{?dist}
Summary: An advanced and flexible OpenVPN user authentication plug-in
@@ -10,11 +7,12 @@ Group: Applications/Internet
License: GPLv2
URL: http://www.eurephia.net/
Source0: http://downloads.sourceforge.net/project/eurephia/eurephia/Beta%20releases/%{name}-%{version}%{?betatag:_%{betatag}}.tar.bz2
-Source1: http://openvpn.net/release/openvpn-%{ovpnver}.tar.gz
+Source1: http://svn.openvpn.net/projects/openvpn/branches/BETA21/openvpn/openvpn-plugin.h
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}{?betatag:_%{betatag}}-root-%(%{__id_u} -n)
-BuildRequires: cmake libxml2-devel libxslt-devel sqlite-devel >= 3.0.0
-Requires: openvpn-eurephia eurephia-sqlite3
+BuildRequires: cmake libxml2-devel libxslt-devel
+BuildRequires: sqlite-devel >= 3.0.0
+Requires: openvpn eurephia-sqlite3
%description
This plug-in enhances OpenVPN by adding user name and password
@@ -23,7 +21,7 @@ minimum one OpenVPN SSL certificate and a user name with a password
assigned. It is also possible to setup several eurephia user names to use
a shared OpenVPN certificate.
-In addition, eurephia will blacklist IP addresses, certificates and usernames
+In addition, eurephia will blacklist IP addresses, certificates and user names
on too many failed attempts and it supports dynamic update of iptables rules
which restricts network access per connection.
@@ -31,7 +29,7 @@ which restricts network access per connection.
Summary: The eurephia SQLite3 database driver
%description sqlite3
-This package conatins the SQLite3 database driver for eurephia
+This package contains the SQLite3 database driver for eurephia
%package iptables
Summary: The eurephia iptables interface module
@@ -51,14 +49,14 @@ This package contains the command line utility to administer and configure
eurephia
%package init
-Summary: Utility for initialising a new eurephia database
+Summary: Utility for initializing a new eurephia database
Requires: eurephia-sqlite3
%description init
-This package provides a program which will initialise the eurephia
+This package provides a program which will initialize the eurephia
database for you. It will guide you through several questions and
save the configuration in the database. When you have configured
-and initialised eurephia, this package should be removed from the
+and initialized eurephia, this package should be removed from the
system.
%package utils
@@ -66,23 +64,24 @@ Summary: Misc. eurephia utilities
%description utils
This package contains useful utilities when debugging eurephia.
-At the moment you will only find saltdecode in this package, which
-will provide some information about the password hash salt.
+At the moment you will only find eurephia_saltdecode in this
+package, which will provide some information about the password
+hash salt.
%prep
-%setup -q -b1 -n openvpn-%{ovpnver}
%setup -q -b0 -n %{name}-%{version}%{?betatag:_%{betatag}}
+cp -v %{_sourcedir}/openvpn-plugin.h %{_builddir}/%{name}-%{version}%{?betatag:_%{betatag}}/
%build
-CFLAGS="%{optflags}" ./configure --prefix %{_prefix} --bin-dir %{_bindir} --xslt-path %{_datadir}/eurephia/xslt --plug-in-dir %{_libdir}/eurephia --plug-in --openvpn-src ../openvpn-%{ovpnver} --fw-iptables --db-sqlite3 --sqlite3-path %{_localstatedir}/lib/eurephia --eurephiadm
+CFLAGS="%{optflags}" ./configure --prefix %{_prefix} --bin-dir %{_bindir} --xslt-path %{_datadir}/eurephia/xslt --plug-in-dir %{_libdir}/eurephia --plug-in --openvpn-src . --fw-iptables --db-sqlite3 --sqlite3-path %{_localstatedir}/lib/eurephia --eurephiadm
make VERBOSE=1
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
install -m 755 utils/eurephia_init $RPM_BUILD_ROOT/%{_bindir}
-install -m 755 utils/saltdecode $RPM_BUILD_ROOT/%{_bindir}
+install -m 755 utils/saltdecode $RPM_BUILD_ROOT/%{_bindir}/eurephia_saltdecode
%clean
rm -rf $RPM_BUILD_ROOT
@@ -118,9 +117,12 @@ rm -rf $RPM_BUILD_ROOT
%files utils
%defattr(-,root,root,-)
%doc LICENSE.txt CREDITS.txt
-%{_bindir}/saltdecode
+%{_bindir}/eurephia_saltdecode
%changelog
+* Wed Jun 30 2010 David Sommerseth <dazo@users.sourceforge.net> - 1.0.0-1
+- Updated and prepared for the eurephia-1.0.0 release
+
* Wed Nov 18 2009 David Sommerseth <dazo@users.sourceforge.net> - 0.9.6-1.beta
- Updated for eurephia-0.9.6_beta and using openvpn-2.1_rc21 source tree