summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2009-03-30 00:34:00 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2009-03-30 00:34:00 +0200
commitcda490e1fc19904d015d8d5853af731d3cd983ea (patch)
tree0f94585eb5b8b506a43865f4497a8d1bb3e62d5f /CMakeLists.txt
parent9922a6f9a6476f680923334789b8857a60f76095 (diff)
downloadeurephia-cda490e1fc19904d015d8d5853af731d3cd983ea.tar.gz
eurephia-cda490e1fc19904d015d8d5853af731d3cd983ea.tar.xz
eurephia-cda490e1fc19904d015d8d5853af731d3cd983ea.zip
Restructured ./configure and improved the path setup
Also added install rules to XSLT files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cfe5526..a281c9d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,10 +10,13 @@ OPTION(EUREPHIADM "Build command line based admin utility" OFF)
OPTION(PLUGIN "Build the eurephia plugin for OpenVPN" OFF)
SET(OPENVPN_SRC "" CACHE STRING "Path to OpenVPN source code")
-SET(PREFIX "/etc/openvpn/eurephia" CACHE STRING "Install prefix for eurephia")
-SET(XSLTROOT "/usr/share/eurephia/xslt" CACHE STRING "Root path for the XSLT templates")
+SET(PREFIX "/usr/local" CACHE STRING "Install prefix for eurephia")
+SET(BINDIR "/usr/local/bin" CACHE STRING "Directory for eurephia binaries")
+SET(PLUGINDIR "/usr/local/lib/eurephia" CACHE STRING "Plug-in path for the eurephia modules")
+SET(XSLTROOT "/usr/local/share/eurephia/xslt" CACHE STRING "Root path for the XSLT templates")
SET(CMAKE_INSTALL_PREFIX ${PREFIX})
+
IF(SQLITE3)
message(STATUS "Will build database interface for SQLite")
SET(subdirs ${subdirs} database/sqlite)