summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2009-03-22 23:14:16 +0100
committerDavid Sommerseth <dazo@users.sourceforge.net>2009-03-22 23:14:16 +0100
commit9acdc869cb8cfd819162744716c17c14d04d2193 (patch)
treea3e7cdd06d3b965c4e52091dbf5134fd5473026b /CMakeLists.txt
parentfe21ea1986f3527864ed0c25cd2f24265f67fb2a (diff)
downloadeurephia-9acdc869cb8cfd819162744716c17c14d04d2193.tar.gz
eurephia-9acdc869cb8cfd819162744716c17c14d04d2193.tar.xz
eurephia-9acdc869cb8cfd819162744716c17c14d04d2193.zip
Added utility to initialise and prepare a eurephia database
Run the utils/eurephia_init program to setup and do the initial configuration of eurephia. It needs 2 required arguments --database-driver <path to database driver> --database-args <arguments to the db driver> This utility will then guide you through a setup for the different configuration parameters used by eurephia.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7b635f1..a8a9e9b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,8 @@
PROJECT(eurephia C)
cmake_minimum_required(VERSION 2.6)
+ADD_DEFINITIONS(-DEUREPHIAVERSION="0.9.4_beta")
+
OPTION(DEBUG "Add more verbose debug information" OFF)
OPTION(SHOW_SECRETS "Show passwords as clear text in logs." OFF)
OPTION(SQLITE3 "Build database driver for SQLite3" OFF)
@@ -67,7 +69,7 @@ IF(PLUGIN)
message(FATAL_ERROR "Missing openvpn-plugin.h ... Is the OpenVPN source code really located here? ${OPENVPN_SRC}")
ENDIF(NOT EXISTS ${CHECK_INCL_FILE})
INCLUDE_DIRECTORIES(BEFORE ${OPENVPN_SRC} .)
- SET(subdirs ${subdirs} plugin)
+ SET(subdirs ${subdirs} plugin utils)
ENDIF(PLUGIN)
INCLUDE(CheckIncludeFile)