summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-12-11 00:05:29 +0100
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-12-11 00:05:29 +0100
commit94b035d4a269bf79374d8b43281cb516e5218a6c (patch)
tree1e9d1f6cf3b29f0d0210eec33d496098edbfe712 /CMakeLists.txt
parentc71f6dab57b454f19f3566b6ed544ff10342ec16 (diff)
downloadeurephia-94b035d4a269bf79374d8b43281cb516e5218a6c.tar.gz
eurephia-94b035d4a269bf79374d8b43281cb516e5218a6c.tar.xz
eurephia-94b035d4a269bf79374d8b43281cb516e5218a6c.zip
Added functions for processing eurephiaACCESSINFO/eurephiaACCESSLIST
Implemented saving VPN access profile to the eurephiaCERTINFO struct and filling the eurephiaACCESSINFO with the proper information needed in the eDBadminGetUserInfo(...) function. The special thing about eurephiaACCESSINFO, is that it will not register duplicate records. And when the eurephiaCERTINFO is free'd, the eurephiaACCESSLIST will automatically be free'd as well.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0678a2b..68b124c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,9 +22,14 @@ IF(EUREPHIADM)
ENDIF(EUREPHIADM)
IF(NOT DATABASE)
- message(FATAL_ERROR "Cannot build eurephia without any database drivers.")
+ message(FATAL_ERROR "Cannot build eurephia without any database drivers.")
ENDIF(NOT DATABASE)
+IF(FW_IPTABLES)
+ SET(FIREWALL on)
+ENDIF(FW_IPTABLES)
+
+
IF(DEBUG)
message(STATUS "DEBUG enabled - might be a security issue")
ADD_DEFINITIONS(-DENABLE_DEBUG)