summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-10-03 12:53:45 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-10-03 12:53:45 +0200
commit75fc3665a86af37b1199128c3debe973f0cae8ea (patch)
tree21f451565a4317d8c023e329fcfd9710a31b8502 /CMakeLists.txt
parent59b850f44e56263460db5e69b9f0a2fcebae4111 (diff)
downloadeurephia-75fc3665a86af37b1199128c3debe973f0cae8ea.tar.gz
eurephia-75fc3665a86af37b1199128c3debe973f0cae8ea.tar.xz
eurephia-75fc3665a86af37b1199128c3debe973f0cae8ea.zip
Made building more dynamic, improved parameter handling in configure and added more parameters
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 20 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c90b7a..f5907f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,15 +16,29 @@ SET(eurephia_auth_SRC
)
OPTION(DEBUG "Add more verbose debug information" OFF)
OPTION(SHOW_SECRETS "Show passwords as clear text in logs." OFF)
-OPTION(SQLITE3 "Build database driver for SQLite3" ON)
+OPTION(SQLITE3 "Build database driver for SQLite3" OFF)
-IF(NOT SQLITE3)
- message(FATAL_ERROR "Cannot build eurephia without any database drivers (-DSQLITE3=ON)")
-ENDIF(NOT SQLITE3)
+
+IF(SQLITE3)
+ message(STATUS "Will build database interface for SQLite")
+ SET(subdirs ${subdirs} database/sqlite)
+ SET(DATABASE ON)
+ENDIF(SQLITE3)
+
+IF(FW_IPTABLES)
+ message(STATUS "Will build iptables firewall module")
+ SET(subdirs ${subdirs} firewall/iptables)
+ENDIF(FW_IPTABLES)
+
+IF(NOT DATABASE)
+ message(FATAL_ERROR "Cannot build eurephia without any database drivers.")
+ENDIF(NOT DATABASE)
IF(DEBUG)
+ message(STATUS "DEBUG enabled - might be a security issue")
ADD_DEFINITIONS(-DENABLE_DEBUG)
IF(SHOW_SECRETS)
+ message(STATUS "SHOW_SECRETS ENABLED -- THIS WILL LOG PASSWORDS IN CLEAR TEXT")
ADD_DEFINITIONS(-DSHOW_SECRETS)
ENDIF(SHOW_SECRETS)
ENDIF(DEBUG)
@@ -82,4 +96,5 @@ ADD_DEFINITIONS(-g -Wall)
ADD_LIBRARY(eurephia-auth MODULE ${eurephia_auth_SRC})
TARGET_LINK_LIBRARIES(eurephia-auth dl pthread rt crypto)
SET_TARGET_PROPERTIES(eurephia-auth PROPERTIES OUTPUT_NAME eurephia-auth PREFIX "")
-SUBDIRS(database/sqlite firewall/iptables)
+
+SUBDIRS(${subdirs})