summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2009-07-21 15:17:54 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2009-07-21 15:17:54 +0200
commit74578b270227c984499dc37c4b436382f6cced1f (patch)
treef70ac98c1837f3892fc2c6038e8cbd332650602a /CMakeLists.txt
parentcd240cc7e292e2fed72e0283c51e2100426866f5 (diff)
downloadeurephia-74578b270227c984499dc37c4b436382f6cced1f.tar.gz
eurephia-74578b270227c984499dc37c4b436382f6cced1f.tar.xz
eurephia-74578b270227c984499dc37c4b436382f6cced1f.zip
Added -fno-delete-null-pointer-checks
This optimisation can be dangerous sometimes, where the C compiler can remove some NULL pointer checks if it believes a pointer is assigned before this check. Sometimes, this is very wrong and can cause an exploit.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07b5cb0..761fae2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,7 @@ SET(PLUGINDIR "/usr/local/lib/eurephia" CACHE STRING "Plug-in path for the eurep
SET(XSLTROOT "/usr/local/share/eurephia/xslt" CACHE STRING "Root path for the XSLT templates")
SET(CMAKE_INSTALL_PREFIX ${PREFIX})
+SET(CMAKE_C_FLAGS "-fno-delete-null-pointer-checks")
IF(SQLITE3)
message(STATUS "Will build database interface for SQLite")