summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2010-07-06 19:16:58 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-07-30 11:02:56 +0200
commit6562a30519273ff9de151ce5488d0dd0c9eb5725 (patch)
tree33cefb778c65f601daae3ba061817d316f35a716 /CMakeLists.txt
parent31128d1d1c2d9de2d3cf6d137e9e80fb00865569 (diff)
downloadeurephia-6562a30519273ff9de151ce5488d0dd0c9eb5725.tar.gz
eurephia-6562a30519273ff9de151ce5488d0dd0c9eb5725.tar.xz
eurephia-6562a30519273ff9de151ce5488d0dd0c9eb5725.zip
Added install rules for man pages
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8ee0d0f..c5ba828 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,7 @@ SET(PREFIX "/usr/local" CACHE STRING "Install prefix for eurephia")
SET(BINDIR "/usr/local/bin" CACHE STRING "Directory for eurephia binaries")
SET(PLUGINDIR "/usr/local/lib/eurephia" CACHE STRING "Plug-in path for the eurephia modules")
SET(XSLTROOT "/usr/local/share/eurephia/xslt" CACHE STRING "Root path for the XSLT templates")
+SET(MANDIR "/usr/local/share/man" CACHE STRING "Path where to install man pages")
# Set install prefix
SET(CMAKE_INSTALL_PREFIX ${PREFIX})
@@ -178,3 +179,6 @@ IF(DEBUG)
ADD_DEFINITIONS(-DSHOW_SECRETS)
ENDIF(SHOW_SECRETS)
ENDIF(DEBUG)
+
+# Install generic man pages
+INSTALL(FILES man/eurephia-variables.7 DESTINATION ${MANDIR}/man7)