summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2013-06-08 02:32:34 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2013-06-09 01:03:29 +0200
commit6554cba9441de42e0c5c455b16fb5f6b39c19e28 (patch)
tree027ed605d3c5556bba853018fd6eb6cf18effc24 /CMakeLists.txt
parentd7b486079a77beb883e3c5e39842dd5c180f3b7b (diff)
downloadeurephia-6554cba9441de42e0c5c455b16fb5f6b39c19e28.tar.gz
eurephia-6554cba9441de42e0c5c455b16fb5f6b39c19e28.tar.xz
eurephia-6554cba9441de42e0c5c455b16fb5f6b39c19e28.zip
auth: Added socket-auth module
This can authenticate username/passwords via a file socket to an authentication service. A simple authentication service written in Python is added as well. Signed-off-by: David Sommerseth <dazo@users.sourceforge.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1297b7f..3a07c83 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -181,7 +181,7 @@ SET_PROPERTY(TARGET common PROPERTY IMPORTED_LOCATION ${CMAKE_SOURCE_DIR}/common
# Start the building. First build the common library, and then the requested eurephia modules
IF(DATABASE OR PLUGIN OR FIREWALL OR EUREPHIADM)
- SUBDIRS(common auth/dummy auth/flatfile ${subdirs})
+ SUBDIRS(common auth/dummy auth/flatfile auth/socket ${subdirs})
ENDIF(DATABASE OR PLUGIN OR FIREWALL OR EUREPHIADM)
# Compile Doxygen docs at the end if requested