summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-12-20 02:26:33 +0100
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-12-20 02:26:33 +0100
commit31148e445a38e6daac0331d3839037dc297cd359 (patch)
tree660abe72a7153f980145a64273e76f03bfdaaa78 /CMakeLists.txt
parent726a4e4c303d1e553e342491e3700162d982fe10 (diff)
downloadeurephia-31148e445a38e6daac0331d3839037dc297cd359.tar.gz
eurephia-31148e445a38e6daac0331d3839037dc297cd359.tar.xz
eurephia-31148e445a38e6daac0331d3839037dc297cd359.zip
certs command: Can parse SSL certificate files when registering cert.
Instead of giving digest, common name, organisation and email address as parameters when registering a new certificate, the function can now take both PEM formated and PKCS12 formated certificate files and extract the needed information automatically. This functionality will only be enabled if OpenSSL v0.9.8 or newer is found.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e84238..0dcd875 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,13 @@ IF(ADMIN_ENABLED)
pkg_search_module(LIBXML2 REQUIRED libxml-2.0 libxml2 libxml>=2.6)
INCLUDE_DIRECTORIES(BEFORE ${LIBXML2_INCLUDE_DIRS})
ADD_DEFINITIONS(-DHAVE_LIBXML2)
- SET(EXTRA_LIBS ${LIBXML2_LIBRARIES})
+ SET(EXTRA_LIBS ${EXTRA_LIBS} ${LIBXML2_LIBRARIES})
+
+ pkg_search_module(OPENSSL OPTIONAL openssl>=0.9.8)
+ IF(OPENSSL_FOUND)
+ ADD_DEFINITIONS(-DHAVE_OPENSSL)
+ SET(EXTRA_LIBS ${EXTRA_LIBS} ${OPENSSL_LIBRARIES})
+ ENDIF(OPENSSL_FOUND)
ENDIF(ADMIN_ENABLED)
IF(NOT DATABASE)