summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-05-12 11:56:27 -0400
committerSimo Sorce <ssorce@redhat.com>2009-05-14 11:34:04 -0400
commitcd42b4bd1c519d70aa2c73e5e79290bb40c30e4f (patch)
tree2f13ceddcaea57825113f33e36c1ad945318eb18 /configure.ac
parente54ce04c11c4a6ff8b5c7bbbd738f70e3da4e101 (diff)
downloadding-libs-cd42b4bd1c519d70aa2c73e5e79290bb40c30e4f.tar.gz
ding-libs-cd42b4bd1c519d70aa2c73e5e79290bb40c30e4f.tar.xz
ding-libs-cd42b4bd1c519d70aa2c73e5e79290bb40c30e4f.zip
Enable building a single libsssd_utils.so from common
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a5fa3d5..e321399 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,8 +23,17 @@ AC_CONFIG_FILES([Makefile
AC_CONFIG_SUBDIRS([collection dhash ini])
-AC_OUTPUT
-
-
-
+AC_DEFUN([WITH_SINGLELIB],
+ [ AC_ARG_WITH([singlelib],
+ [AC_HELP_STRING([--with-singlelib],
+ [Whether to build a shared object containing all sssd_utils [no]]
+ )
+ ],
+ [],
+ with_singlelib=yes
+ )
+ ])
+
+AM_CONDITIONAL([SINGLELIB], [test x$with_singlelib = xyes ])
+AC_OUTPUT