summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@redhat.com>2009-04-16 17:48:13 -0400
committerSimo Sorce <ssorce@redhat.com>2009-04-22 04:42:43 -0400
commit5d237157deefb39db63acdd950bd67c7809415f6 (patch)
treea571ec93c80b4abd8c190005735cfb9ec2b521cc /configure.ac
parent7b5f297ac811213629789924cf7f69e520185e98 (diff)
downloadding-libs-5d237157deefb39db63acdd950bd67c7809415f6.tar.gz
ding-libs-5d237157deefb39db63acdd950bd67c7809415f6.tar.xz
ding-libs-5d237157deefb39db63acdd950bd67c7809415f6.zip
add dynamic hash table data structure implementation
Apply suggested fixes by Simo after code review * return statements no longer use () unless it's an expression * remove all use of assert() in library * use bool,true,false instead of int,TRUE,FALSE * add check for NULL hash table in public entry points * example code in header file now a seperate file * assure consistent use of unsigned long data type * add more debugging support * break out generation of integer key into convert_key() function * table parameters now tunable rather than hardcoded * table can now accept custom alloc()/free() functions * add function create_table_ex() to pass extra table parameters * remove MUL(), DIV(), MOD() macros * hash statistics now separate struct which can be queried * test program now accepts tuning parameters, iteration count; has better error checking and reporting fix min/max load factor comman line args in test program
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8804b4d..120d103 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,7 +17,11 @@ AC_ARG_ENABLE([trace],
AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TRACE_VAR],["-DTRACE_LEVEL=$trace_level"])])
-AC_CONFIG_FILES([Makefile collection/Makefile collection/collection.pc ini/Makefile ini/ini_config.pc trace/Makefile])
+AC_CONFIG_FILES([Makefile
+ collection/Makefile collection/collection.pc
+ dhash/Makefile dhash/dhash.pc
+ ini/Makefile ini/ini_config.pc
+ trace/Makefile])
AC_OUTPUT