summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-04-06 09:30:01 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-04-06 15:59:21 -0400
commit548fb76622cacbdf4416f07b718f1bdd93924a9f (patch)
tree5b65b939ec4877cbd1e8f3b7a84897bb579eca0a /configure.ac
downloadding-libs-548fb76622cacbdf4416f07b718f1bdd93924a9f.tar.gz
ding-libs-548fb76622cacbdf4416f07b718f1bdd93924a9f.tar.xz
ding-libs-548fb76622cacbdf4416f07b718f1bdd93924a9f.zip
First commit of basic collection API.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..83a2c18
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,25 @@
+AC_INIT([elapi], [0.0], [dpal@redhat.com])
+AC_CONFIG_SRCDIR([collection/collection.c])
+AC_CONFIG_AUX_DIR([build])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_PROG_CC
+AC_PROG_LIBTOOL
+AC_PROG_INSTALL
+
+AC_CONFIG_HEADERS([config.h])
+
+
+# Enable trace build
+AC_ARG_ENABLE([trace],
+ [AS_HELP_STRING([--enable-trace],[build with low level tracing enabled])],
+ [trace_level="$enableval"],
+ [trace_level="0"])
+AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TRACE_VAR],["-DTRACE_LEVEL=$trace_level"])])
+
+
+AC_CONFIG_FILES([Makefile collection/Makefile])
+AC_OUTPUT
+
+
+
+