summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2010-06-18 14:52:21 -0400
committerStephen Gallagher <sgallagh@redhat.com>2010-09-22 14:57:52 -0400
commite65ef66621b6d59580018f6ecf1f9bffacc27372 (patch)
tree5604909ac4203aa1b1ad9f0979b834e7d6f670e9 /Makefile.am
parentb8b0158e4f84b4b2ba15e3bdc4ea94ff29aefc82 (diff)
downloadding-libs-e65ef66621b6d59580018f6ecf1f9bffacc27372.tar.gz
ding-libs-e65ef66621b6d59580018f6ecf1f9bffacc27372.tar.xz
ding-libs-e65ef66621b6d59580018f6ecf1f9bffacc27372.zip
Introducing basic objects
The first basic object is extensible buffer.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8c59f3f..6e21d40 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,7 @@ AM_CPPFLAGS = \
-I$(srcdir)/refarray \
-I$(srcdir)/dhash \
-I$(srcdir)/ini \
+ -I$(srcdir)/basicobjects \
-I$(srcdir) \
-I$(srcdir)/trace \
$(TRACE_LEVEL)
@@ -181,6 +182,32 @@ if HAVE_DOXYGEN
endif
##############################################################################
+# basicobjects
+##############################################################################
+
+lib_LTLIBRARIES += libbasicobjects.la
+dist_pkgconfig_DATA += basicobjects/basicobjects.pc
+dist_include_HEADERS += basicobjects/simplebuffer.h
+
+libbasicobjects_la_SOURCES = \
+ basicobjects/simplebuffer.c \
+ trace/trace.h
+libbasicobjects_la_LDFLAGS = \
+ -version-info 1:0:0
+
+check_PROGRAMS += simplebuffer_ut
+TESTS += simplebuffer_ut
+simplebuffer_ut_SOURCES = basicobjects/simplebuffer_ut.c
+simplebuffer_ut_LDADD = libbasicobjects.la
+
+basicobjects-docs:
+if HAVE_DOXYGEN
+ cd basicobjects; \
+ $(DOXYGEN) basicobjects.cfg.doxy
+endif
+
+
+##############################################################################
# ini_config
##############################################################################
@@ -276,7 +303,7 @@ endif
tests: all $(check_PROGRAMS)
-docs: path_utils-docs collection-docs ref_array-docs ini_config-docs
+docs: path_utils-docs collection-docs ref_array-docs ini_config-docs basicobjects-docs
clean-local:
rm -Rf doc