summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-07-13 19:35:31 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-15 11:19:46 -0400
commit51b3a661529f8e3fd5ada94b95d4ba393e339dd8 (patch)
treee96497349d5740445adfe57648469146b5256c4c /Makefile.am
parent18871cab92aef80bd4a856454a77f8808984dbce (diff)
downloadding-libs-51b3a661529f8e3fd5ada94b95d4ba393e339dd8.tar.gz
ding-libs-51b3a661529f8e3fd5ada94b95d4ba393e339dd8.tar.xz
ding-libs-51b3a661529f8e3fd5ada94b95d4ba393e339dd8.zip
ELAPI First part of the interface
This is just a part of the interface, a beginning. Most likely some of the functions will be altered but it is a starting point. For example in future there will be a way to override some of the parts of the default template using the application configuration file. Removed obfuscation of the data types based on discussion with Simo.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d3329c9..445a843 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = trace collection ini dhash path_utils
+SUBDIRS = trace collection ini dhash path_utils elapi
if SINGLELIB
# Build all components as a single shared library
lib_LTLIBRARIES = libsssd_util.la
@@ -7,11 +7,12 @@ libsssd_util_la_SOURCES =
libsssd_util_la_LIBADD = \
collection/libcollection.la \
ini/libini_config.la \
- dhash/libdhash.la
+ dhash/libdhash.la \
+ elapi/libelapi.la
libsssd_util_la_CFLAGS = $(AM_CFLAGS) \
-I ./collection \
-I ./ini \
-I ./dhash \
+ -I ./elapi \
-I ./trace
endif
-