summaryrefslogtreecommitdiffstats
path: root/girepository/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'girepository/Makefile.am')
-rw-r--r--girepository/Makefile.am54
1 files changed, 0 insertions, 54 deletions
diff --git a/girepository/Makefile.am b/girepository/Makefile.am
deleted file mode 100644
index 8bdb462..0000000
--- a/girepository/Makefile.am
+++ /dev/null
@@ -1,54 +0,0 @@
-AUTOMAKE_OPTIONS = 1.7
-PLATFORM_VERSION = 2.0
-
-pkgpyexecdir = $(pyexecdir)/gtk-2.0/girepository
-
-if BUILD_GIREPOSITORY
-
-INCLUDES = \
- -I$(top_srcdir)/gobject \
- $(PYTHON_INCLUDES) \
- $(PYGOBJECT_CFLAGS) \
- $(GOBJECT_INTROSPECTION_CFLAGS)
-
-# girepository python scripts
-pygirepositorydir = $(pkgpyexecdir)
-pygirepository_PYTHON = \
- __init__.py \
- importer.py \
- module.py \
- repository.py \
- btypes.py
-
-pygioverridesdir = $(pkgpyexecdir)/overrides
-pygioverrides_PYTHON = $(srcdir)/overrides/*.py
-
-# linker flags
-common_ldflags = -module -avoid-version
-if PLATFORM_WIN32
-common_ldflags += -no-undefined
-endif
-
-CLEANFILES =
-EXTRA_DIST =
-
-# repo module
-repo_la_CFLAGS = -O0
-repo_la_LDFLAGS = $(common_ldflags) -export-symbols-regex initrepo
-repo_la_LIBADD = $(GOBJECT_INTROSPECTION_LIBS)
-repo_la_SOURCES = \
- bank-repository.c \
- bank-argument.c \
- bank-info.c \
- bank.c \
- bank.h
-
-pygirepository_LTLIBRARIES = repo.la
-
-all: $(pygirepository_LTLIBRARIES:.la=.so)
-clean-local:
- rm -f $(pygirepository_LTLIBRARIES:.la=.so)
-.la.so:
- $(LN_S) .libs/$@ $@ || true
-
-endif # BUILD_GIREPOSITORY