summaryrefslogtreecommitdiffstats
path: root/gio/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gio/Makefile.am')
-rw-r--r--gio/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/gio/Makefile.am b/gio/Makefile.am
index d47dda9..a0f356d 100644
--- a/gio/Makefile.am
+++ b/gio/Makefile.am
@@ -93,3 +93,12 @@ endif
--prefix py$(*F) $*.defs) > $(*D)/gen-$(*F).c \
&& cp $(*D)/gen-$(*F).c $(*D)/$(*F).c \
&& rm -f $(*D)/gen-$(*F).c
+
+
+if BUILD_GIO
+all: $(pkgpyexec_LTLIBRARIES:.la=.so)
+clean-local:
+ rm -f $(pkgpyexec_LTLIBRARIES:.la=.so)
+.la.so:
+ $(LN_S) .libs/$@ $@
+endif