summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2006-04-11 15:14:36 +0000
committerJohan Dahlin <johan@src.gnome.org>2006-04-11 15:14:36 +0000
commitc10ecb8121f62361f744fd3d6034c9339890f6f8 (patch)
tree77cae05805368e46a7a4b34dff8df104c4d630cb /tests/Makefile.am
parentdd6f0893eaea89726576fc960257334d00d4544e (diff)
downloadpygobject-c10ecb8121f62361f744fd3d6034c9339890f6f8.tar.gz
pygobject-c10ecb8121f62361f744fd3d6034c9339890f6f8.tar.xz
pygobject-c10ecb8121f62361f744fd3d6034c9339890f6f8.zip
Turn gobject into a package; move _gobject to gobject._gobject and
add gobject/__init__.py. Update macros and testsuite.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 39ba16d..8ccb3c3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -37,6 +37,12 @@ tests = \
testhelper.la: $(testhelper_la_OBJECTS) $(testhelper_la_DEPENDENCIES)
$(LINK) -rpath $(pkgpyexecdir) $(testhelper_la_LDFLAGS) $(testhelper_la_OBJECTS) $(testhelper_la_LIBADD) $(LIBS)
-check-local:
+check-local: $(top_srcdir)/gobject/__init__.py
+ @if test "$(top_builddir)" != "$(top_srcdir)"; then \
+ cp $(top_srcdir)/gobject/__init__.py $(top_builddir)/gobject/__init__.py; \
+ fi
@$(PYTHON) $(srcdir)/runtests.py $(top_builddir) $(top_srcdir)
+ @if test "$(top_builddir)" != "$(top_srcdir)"; then \
+ rm -f $(top_builddir)/gobject/__init__.py*; \
+ fi
@rm -fr *.pyc