summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@gnome.org>2008-07-20 10:43:41 +0000
committerJohan Dahlin <johan@src.gnome.org>2008-07-20 10:43:41 +0000
commit6628e24baebc6dd40f9e76d10391ea5c06d3398a (patch)
tree68b587325b10d5616381c508609702027db8ba74 /glib/Makefile.am
parentaf2dfa166520a243ea05ff7d4bd5a1fa103d8e0b (diff)
downloadpygobject-6628e24baebc6dd40f9e76d10391ea5c06d3398a.tar.gz
pygobject-6628e24baebc6dd40f9e76d10391ea5c06d3398a.tar.xz
pygobject-6628e24baebc6dd40f9e76d10391ea5c06d3398a.zip
Add glib bindings, currently not installed or used. Add some internal API
2008-07-20 Johan Dahlin <johan@gnome.org> * Makefile.am: * configure.ac: * glib/Makefile.am: * glib/__init__.py: * glib/glibmodule.c (pyg_destroy_notify), (get_handler_priority), (pyg_handler_marshal), (pyg_idle_add), (pyg_timeout_add), (pyg_timeout_add_seconds), (iowatch_marshal), (pyg_io_add_watch), (pyg_source_remove), (pyg_main_context_default), (child_watch_func), (child_watch_dnotify), (pyg_child_watch_add), (pyg_markup_escape_text), (pyg_get_current_time), (pyg_main_depth), (pyg_filename_display_name), (pyg_filename_display_basename), (pyg_filename_from_utf8), (pyg_get_application_name), (pyg_set_application_name), (pyg_get_prgname), (pyg_set_prgname), (pyg_register_api), (pyg_register_error), (pyg_register_version_tuples), (init_glib): * glib/pyglib-private.h: * glib/pyglib.c (pyglib_init), (pyglib_init_internal), (pyglib_gil_state_ensure), (pyglib_gil_state_release), (pyglib_enable_threads), (pyglib_gil_state_ensure_py23), (pyglib_gil_state_release_py23), (pyglib_error_check): * glib/pyglib.h: * glib/pygspawn.c (pyg_pid_close), (pyg_pid_free), (pyg_pid_tp_init), (pyg_pid_new), (_pyg_spawn_async_callback), (pyglib_spawn_async), (pyg_spawn_register_types): * glib/pygspawn.h: Add glib bindings, currently not installed or used. Add some internal API and move over a couple of functions from the gobject module. Still very much a work in progress. svn path=/trunk/; revision=839
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
new file mode 100644
index 0000000..7e57580
--- /dev/null
+++ b/glib/Makefile.am
@@ -0,0 +1,33 @@
+AUTOMAKE_OPTIONS = 1.7
+PLATFORM_VERSION = 2.0
+INCLUDES = $(PYTHON_INCLUDES) $(GLIB_CFLAGS) -DPY_SSIZE_T_CLEAN
+
+# Workaround for automake so we can build shared library which are not
+# going to be installed
+noinstshared_LTLIBRARIES = libpyglib.la _glib.la
+noinstshareddir = /tmp
+install-noinstsharedLTLIBRARIES: # prevent it from being installed
+
+common_ldflags = -module -avoid-version
+if PLATFORM_WIN32
+common_ldflags += -no-undefined
+endif
+
+libpyglib_la_CFLAGS = $(GLIB_CFLAGS)
+libpyglib_la_LIBADD = $(GLIB_LIBS) $(FFI_LIBS)
+libpyglib_la_SOURCES = \
+ pyglib.c \
+ pyglib.h \
+ pyglib-private.h
+
+_glib_la_CFLAGS = $(GLIB_CFLAGS)
+_glib_la_LDFLAGS = $(common_ldflags) -export-symbols-regex init_glib
+_glib_la_LIBADD = $(GLIB_LIBS) libpyglib.la
+_glib_la_SOURCES = \
+ glibmodule.c \
+ pygspawn.c \
+ pygspawn.h
+
+if PLATFORM_WIN32
+_glib_la_CFLAGS += -DPLATFORM_WIN32
+endif