summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon van der Linden <simon.vanderlinden@student.uclouvain.be>2009-05-28 17:45:11 +0200
committerSimon van der Linden <simon.vanderlinden@student.uclouvain.be>2009-06-08 19:08:17 +0200
commite4f2a5ef8734cf40cf8345d442612db1f6c62d5a (patch)
tree45a694e46204e770e184aa4fcaaf8e23075235be /configure.ac
parentf5ab5046fe9b67ec5e8fc64679e1a3d01787af7e (diff)
downloadpygobject-e4f2a5ef8734cf40cf8345d442612db1f6c62d5a.tar.gz
pygobject-e4f2a5ef8734cf40cf8345d442612db1f6c62d5a.tar.xz
pygobject-e4f2a5ef8734cf40cf8345d442612db1f6c62d5a.zip
Introduces the girepository module from the former PyBank.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index acd269e..ed1f1a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,7 @@ dnl versions of packages we require ...
m4_define(glib_required_version, 2.14.0)
m4_define(gio_required_version, 2.16.0)
m4_define(giounix_required_version, 2.16.0)
+m4_define(gobject_introspection_required_version, 0.6.3)
AC_INIT(pygobject, pygobject_version,
[http://bugzilla.gnome.org/enter_bug.cgi?product=pygobject])
@@ -199,6 +200,16 @@ if test -n "$export_dynamic"; then
GIOUNIX_LIBS=`echo $GIOUNIX_LIBS | sed -e "s/$export_dynamic//"`
fi
+dnl gobject_introspection
+PKG_CHECK_MODULES(GOBJECT_INTROSPECTION, gobject-introspection-1.0 >= gobject_introspection_required_version,
+ have_gobject_introspection=true, have_gobject_introspection=false)
+AC_SUBST(GOBJECT_INTROSPECTION_CFLAGS)
+AC_SUBST(GOBJECT_INTROSPECTION_LIBS)
+AM_CONDITIONAL(BUILD_GOBJECT_INTROSPECTION, $have_gobject_introspection)
+if test -n "$export_dynamic"; then
+ GOBJECT_INTROSPECTION_LIBS=`echo $GOBJECT_INTROSPECTION_LIBS | sed -e "s/$export_dynamic//"`
+fi
+
dnl add required cflags ...
if test "x$GCC" = "xyes"; then
JH_ADD_CFLAG([-Wall])
@@ -226,6 +237,7 @@ AC_CONFIG_FILES(
glib/Makefile
gobject/Makefile
gio/Makefile
+ girepository/Makefile
examples/Makefile
tests/Makefile
PKG-INFO)