summaryrefslogtreecommitdiffstats
path: root/codegen/libcodegen/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2010-04-15 11:41:09 -0400
committerJohn (J5) Palmieri <johnp@redhat.com>2010-04-15 13:56:17 -0400
commit5cd24966b709de7c75a83018297d8dfb3481ddb0 (patch)
tree1b927c7497822dadc5074e2d47146910a3f6c3ca /codegen/libcodegen/Makefile.am
parentbc863e519f1cbc8b8304f88ff308ca1bacd676b7 (diff)
downloadpygobject-5cd24966b709de7c75a83018297d8dfb3481ddb0.tar.gz
pygobject-5cd24966b709de7c75a83018297d8dfb3481ddb0.tar.xz
pygobject-5cd24966b709de7c75a83018297d8dfb3481ddb0.zip
fixed autotools build
* some file moved from codegen to codegen/libcodegen - create Makefile.am in libcodegen dir - remove refs to files and add the libcodegen subdir in codegen/Makefile.am * add AM_MAINTAINER_MODE to configure.ac - allows ./autogen.sh to be run without flags
Diffstat (limited to 'codegen/libcodegen/Makefile.am')
-rw-r--r--codegen/libcodegen/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/codegen/libcodegen/Makefile.am b/codegen/libcodegen/Makefile.am
new file mode 100644
index 0000000..cbf227c
--- /dev/null
+++ b/codegen/libcodegen/Makefile.am
@@ -0,0 +1,13 @@
+PLATFORM_VERSION = 2.0
+
+libcodegendir = $(pkgdatadir)/$(PLATFORM_VERSION)/codegen/libcodegen
+libcodegen_SCRIPTS = \
+ __init__.py \
+ argtypes.py \
+ definitions.py \
+ defsparser.py \
+ docextract.py \
+ override.py \
+ reversewrapper.py
+
+EXTRA_DIST = $(libcodegen_SCRIPTS)