summaryrefslogtreecommitdiffstats
path: root/python-zope-viewlet/F-13/python-zope-viewlet.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zope-viewlet/F-13/python-zope-viewlet.spec')
-rw-r--r--python-zope-viewlet/F-13/python-zope-viewlet.spec62
1 files changed, 62 insertions, 0 deletions
diff --git a/python-zope-viewlet/F-13/python-zope-viewlet.spec b/python-zope-viewlet/F-13/python-zope-viewlet.spec
new file mode 100644
index 0000000..470cf35
--- /dev/null
+++ b/python-zope-viewlet/F-13/python-zope-viewlet.spec
@@ -0,0 +1,62 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname zope.viewlet
+%global version 3.7.2
+%global release 1
+
+Summary: Zope Viewlets
+Name: python-zope-viewlet
+Version: %{version}
+Release: %{release}%{?dist}
+Source0: http://pypi.python.org/packages/source/z/%{modname}/%{modname}-%{version}.tar.gz
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://pypi.python.org/pypi/zope.viewlet
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-zope-browserpage
+Requires: python-zope-component
+Requires: python-zope-configuration
+Requires: python-zope-contentprovider
+Requires: python-zope-event
+Requires: python-zope-i18nmessageid
+Requires: python-zope-interface
+Requires: python-zope-location
+Requires: python-zope-publisher
+Requires: python-zope-schema
+Requires: python-zope-security
+Requires: python-zope-traversing
+
+%description
+Viewlets provide a generic framework for building pluggable user interfaces.
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT%{python_sitelib}/zope/viewlet/*.txt
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE.txt CHANGES.txt COPYRIGHT.txt
+%doc src/zope/viewlet/*.txt
+%{python_sitelib}/zope/viewlet/
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Thu Jun 17 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.7.2-1
+- Initial packaging