summaryrefslogtreecommitdiffstats
path: root/python-zope-tal/F-13/python-zope-tal.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zope-tal/F-13/python-zope-tal.spec')
-rw-r--r--python-zope-tal/F-13/python-zope-tal.spec54
1 files changed, 54 insertions, 0 deletions
diff --git a/python-zope-tal/F-13/python-zope-tal.spec b/python-zope-tal/F-13/python-zope-tal.spec
new file mode 100644
index 0000000..265e505
--- /dev/null
+++ b/python-zope-tal/F-13/python-zope-tal.spec
@@ -0,0 +1,54 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname zope.tal
+%global version 3.5.2
+%global release 1
+
+Summary: Zope 3 Template Application Languate (TAL)
+Name: python-zope-tal
+Version: %{version}
+Release: %{release}%{?dist}
+Source0: http://pypi.python.org/packages/source/z/%{modname}/%{modname}-%{version}.zip
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://pypi.python.org/pypi/zope.tal
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-zope-i18nmessageid
+Requires: python-zope-interface
+
+%description
+The Zope3 Template Attribute Languate (TAL) specifies the custom namespace
+and attributes which are used by the Zope Page Templates renderer to inject
+dynamic markup into a page. It also includes the Macro Expansion for TAL
+(METAL) macro language used in page assembly.
+
+%prep
+%setup -q -n %{modname}-%{version}
+sed -i -e '/^#! *\//, 1d' src/zope/tal/*.py src/zope/tal/tests/*.py
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc CHANGES.txt README.txt
+%{python_sitelib}/zope/tal/
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Thu Jun 17 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.5.2-1
+- Initial packaging