summaryrefslogtreecommitdiffstats
path: root/python-zope-password/F-13/python-zope-password.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zope-password/F-13/python-zope-password.spec')
-rw-r--r--python-zope-password/F-13/python-zope-password.spec52
1 files changed, 52 insertions, 0 deletions
diff --git a/python-zope-password/F-13/python-zope-password.spec b/python-zope-password/F-13/python-zope-password.spec
new file mode 100644
index 0000000..ed5594e
--- /dev/null
+++ b/python-zope-password/F-13/python-zope-password.spec
@@ -0,0 +1,52 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname zope.password
+%global version 3.6.1
+%global release 1
+
+Summary: Password encoding and checking utilities
+Name: python-zope-password
+Version: %{version}
+Release: %{release}%{?dist}
+Source0: http://pypi.python.org/packages/source/z/%{modname}/%{modname}-%{version}.tar.gz
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://pypi.python.org/pypi/zope.password
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-zope-component
+Requires: python-zope-configuration
+Requires: python-zope-interface
+
+%description
+This package provides a password manager mechanism. Password manager is an
+utility object that can encode and check encoded passwords.
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE.txt CHANGES.txt README.txt COPYRIGHT.txt
+%{python_sitelib}/zope/password/
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Fri Jun 18 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.6.1-1
+- Initial packaging