summaryrefslogtreecommitdiffstats
path: root/python-zope-location/F-13/python-zope-location.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zope-location/F-13/python-zope-location.spec')
-rw-r--r--python-zope-location/F-13/python-zope-location.spec54
1 files changed, 54 insertions, 0 deletions
diff --git a/python-zope-location/F-13/python-zope-location.spec b/python-zope-location/F-13/python-zope-location.spec
new file mode 100644
index 0000000..41cce37
--- /dev/null
+++ b/python-zope-location/F-13/python-zope-location.spec
@@ -0,0 +1,54 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname zope.location
+%global version 3.9.0
+%global release 1
+
+Summary: Zope Location
+Name: python-zope-location
+Version: %{version}
+Release: %{release}%{?dist}
+Source0: http://pypi.python.org/packages/source/z/%{modname}/%{modname}-%{version}.zip
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://pypi.python.org/pypi/zope.location/
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-zope-interface
+Requires: python-zope-schema
+Requires: python-zope-component
+Requires: python-zope-proxy
+
+%description
+This package provides the location class for Zope.
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT%{python_sitelib}/zope/location/*.txt
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc CHANGES.txt README.txt
+%doc src/zope/location/*.txt
+%{python_sitelib}/zope/location/
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Thu Jun 17 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.9.0-1
+- Initial packaging